Forum Discussion

jill_r_'s avatar
New Contributor

RDK-03033 Error....want it fixed or give me back my old receiver. This is unacceptable.

I am joining the long list of Cox customers who “upgraded” to new Contour 2 receivers. Immediately I started suffering from the RDK-03033 error. Of course I checked all connections repeatedly and have suffered through too many restarts to count. Add to that at least four separate remote sessions with Cox to try to diagnose and fix problem. The last session took more that two hours and no resolution was received. When I asked if a technician could please be scheduled to come out and personally diagnose the problem, I was told to be prepared to pay a $75 installation service fee.

At no point was I ever told this is a common problem with no known resolution. I’m finding out that this is happening A LOT. Someone please tell me why I am paying $200  a month for the aggravation of having to endure a 15-minute reboot process every time I want to change the channel???

I’m fed up and looking for a solution. Rabbit ears are looking pretty attractive at this point. What’s the answer Cox?

8 Replies

  • KevinM2's avatar
    Former Moderator
    Hi Jill R, we are truly sorry to hear about the Contour 2 issues, and I want to help resolve this for you in any way I can. Are both Contour receivers impacted by this RDK-03033 error? Do you have a splitter, by chance? If so, are you able to bypass this for troubleshooting purposes to see if that temporarily adds relief? In regards to sending out a service technician, if the issue is related to the Cox equipment or Cox wiring, there is no charge assessed on the account. Please feel free to email us at, for additional troubleshooting support. -Kevin M. Cox Support Forum Moderator
  • Having the same issue here... wasted all day rebooting and with much more frequency than in the past. Now I can no longer get past the Welcome banner and the Contour "boot'... I even tried resetting from the "Cox Connect" iPhone app hoping it was just an bad system update. To no avail. Seemed to work for an evening but this morning right back to the same *** issue. Nothing has changed on my side. No splitters added and the such. May just take the Contour back and get a replacement unit.

    • JonathanJ's avatar
      Former Moderator

      Sounds like the box not getting a signal. We suggest first checking the coax cable to make sure their hand tight on all ends and have no kinks. Also, could be a bad splitter or amp if you have one. If you have more than one contour box are they getting the same error? If you still getting the error after trying that please email the full-service address and name to so we can check the signal levels.

      Jonathan J
      Cox Moderator
      • eminiR2k's avatar

        All connectors are tight. All the non-Contour mini-boxes that we have in the home (4) are operating fine. So we are definitely getting a signal. This Contour box has been giving us issues for awhile. Also, I ran DOCSIS WAN ( and all the numbers seem good (within acceptable)...

  • Just an FYI: It came down to a bad Contour box (predicted based on behavior). New box working as expected.