Forum Discussion

sirbromeo's avatar
New Contributor

ASUS RT-AC88U Router showing "Your ISP's DHCP does not function correctly" after recent outage resolved


I've been having problems for a couple days with a separate ASUS router to my Arris tm3402a modem from cox. There was a major outage in my neighborhood that caused internet to go down for a couple days (I think the power company cut a cable line or something) and after it was resolved my router showed this message about DHCP not being configured correctly from ISP. Did some research about this modem and found out a lot of people have had issues with 2.4 G connections and weird drop-offs.

Eventually, I got frustrated enough with it that I called tech support to have a technician to come check it out. But after unplugging the cable line outside in the box and plugging it back in and doing a power cycle on the modem it came back on. And sure enough after a power cycle on the router it also showed full connectivity.

I thought the problem was fixed so I cancelled the appointment to not waste the technician's time and avoid a fee for repairs that looked like a crank call. However, this morning, I come to find out that I had lost connectivity. My router settings showed that a network cable was unplugged even though all the lights were on on both the router and the modem. I plugged the modem into a PC and there was no internet connection. Eventually after power cyclings and resetting the modem it worked again...but I don't know why. And I feel like there is more to it than that. Am I going to have to do this every day or should I just choke up the fee to have a tech come look at it?

The ASUS router seems fine despite some bad reviews...I even tried my trusty trendnet dual band and it seemed to have similar issues.

Any ideas?



2 Replies

  • Andrew_Wees's avatar
    Contributor III

    factory reset the router sounds like the router was not fully reset after cox outage

  • sirbromeo's avatar
    New Contributor

    EDIT: The bad reviews were about the router not the modem. The modem has been a CHAMP up until this incident.