Ping Spikes each minute

Hi, I have been trying to resolve this issue for a while now. 

I have had 2 technicians come out now, spoken with 4 customer representatives online and gone up to the Cox store once on top of signing up for the Cox complete care and still the issue is not resolved.

I am on ethernet and have tested my pc after kicking all other devices off of the network this has not worked. I was initially suspicious that it could be a node congestion problem but I am unsure. I have run pingplotter and see that every minute or so there are very higher spikes upwards of 500ms sometimes. Recently I was disqualified from an online tournament from this issue. Which is extremely frustrating especially because I am at a loss with this. 

The first technician ran some test ran some tests off of his gameboy color and told me he was 99% sure that it was the PW3 Cox router/modem I had that was less than 1.5 years old, he didn't have a spare so I was advised to go up to cox to replace it. Once I tested the new PW6 I had the same problem so another technician was sent out. To which he advised this would have to go higher as it above them. 

I reached out to customer support to inquire and they offered to escalate the issue. Today and went to check the status of this only to discover that there was no evidence of this every being recorded. 

I have tried to take action on this as best as I could and am happy to hear some advise or suggestions on the matter. Unfortunately I have spend alot of time and money now dealing with Cox and have not gotten anywhere.