Forum Discussion

cbaird01's avatar
cbaird01
New Contributor
12 months ago

WiFi for Desktop PC is horribly inconsistent

Just recently got internet going on 5/1/2023. All my devices, it seems like the wifi works extremely well, but for my desktop PC, it is really bad. You may think this is a desktop issue, but its not. I have used wifi in the past, but I've never had an issue like this. I'm currently using the Netgear nighthawk AC1900 usb 3.0 dual band adapter as the wifi antenna, and the router is the Cox panoramic wifi. I'm not sure how, but I can barely get anything going for a consistent period of time when it comes to gaming. I normally would direct connect, but the tech said that the fiber can only be connected to the router in my closet, which I feel is just a terrible place to have a router to begin with. Last time I had used Cox was just a year ago, same exact plan and same exact router, yet they were able to connect the router to the living room where my desk was located, and I could directly connect there.

10 Replies

Replies have been turned off for this discussion
  • Lovemylab's avatar
    Lovemylab
    Contributor III

    What's the signal strength at the PC location? Have you checked it with WiFi Analyzer or WiFiman? I'd check both the 2.4 and 5 ghz levels, just toggle the display on your phone from the application. 

  • WiderMouthOpen's avatar
    WiderMouthOpen
    Esteemed Contributor

    Run a ethernet wire from where the ONT and router are to where your desktop is. Gamers shouldn't game on wireless if at all possible IMO. With that said, how do you have the wireless settings configured? Do you have the two bands(2.4 and 5Ghz) separated? if so, are you connecting to 5Ghz?

    • cbaird01's avatar
      cbaird01
      New Contributor

      Yeah I agree. I definitely don't want to connect wirelessly, but the ethernet cable would have to run from my closet, through my bedroom, and into the living room where my desk is. It'd be super intrusive. Also, for some reason, there isn't an indication of a separate network. In the past, I've had the option to select either the 2.4 or the 5, but not this time so I'm not sure what happened.

      • WiderMouthOpen's avatar
        WiderMouthOpen
        Esteemed Contributor

        See step 5 of these instructions and uncheck the box for "Use different names and passwords for 2.4 GHz and 5 GHz WiFi". That should disable band steering and separate the 2.4Ghz from the 5Ghz network name. Then connect to the 5Ghz network and see if your connection is any better. If so, it is probably 2.4Ghz congestion. If not, try updating your adapters software.