Forum Discussion

ILC's avatar
New Contributor
6 years ago

ONCE AGAIN... Outlook keeps prompting to "Enter Network Password" when all passwords are in order

This seems to happen periodically (this is my third time inquiring about this within the last 3 or so years). My Outlook settings are all fine, including passwords, ports, and so on. But for whatever reason, the server refuses to recognize my account/login info, and I get the dreaded "Enter Network Password" pop-up -- over and over and over again, for most of my email accounts -- and this happens on various devices, so it is NOT an Outlook issue. With email checking every 5 minutes, my time is mostly spent OK'ing these pop-ups, which is extremely disruptive. Email eventually does send and download, but the system is just not working as it should.

It seems that every time I post, something gets done on your end, and the problem disappears altogether for a while. Could you please share what the solution is (I see others are finding themselves in the same proposition), and most of all, IMPLEMENT A DEFINITIVE FIX? The way things are with these disruptive pop-ups is just untenable. If this does not get fixed I will be forced to find an alternate provider.

Please let me know what can be done. Thank you!

15 Replies

Replies have been turned off for this discussion
  • suzs's avatar
    New Contributor
    I am having the same issue today 27 Feb 2018 Outlook keeps prompting to "Enter Network Password" when all passwords are in order All my network setting are correct. Please help. Thank you.
  • handy2sum's avatar
    New Contributor

    Same here - we are getting so annoyed witht he popup (Internet Email - enter your user name and pasword for the following server []) ALL THE TIME.  It goes away for a period of time and then returns.  I'm looking at the blasted popup right now- just checked OK.  All my settings are fine.  I use Outlook 2010.  Husband uses Outlook 2013.  Happens to both of us.  Recently its been popping up every 5-10 min (or more frequently). Cox support (Tier 1 and 2) are no help - claim its not their problem its Microsoft - unacceptable response!  Have tried working with them several times and each time we go through all my settings, change passwords etc etc and nothing gets resolved. Been searching through various forums dating back years and seems that this issue has been around for some time.  Why can't Cox fix it??  (and just got another blasted popup)

    Please provide a definative solution!!!

  • StephanieA's avatar
    Former Moderator
    Hi Everyone,

    We can confirm what the settings should be in the email client. Once the settings are confirmed and the issue continues, we are not able to offer any additional support for a third party program. There are different setting requirements for the email client and it only take one being wrong to cause an error. Changing the options to something different than what is provided by us is not recommended. Please use this link and pay close attention to the server name, port number and security type. If the settings are correct and you are still having issues, we suggest contacting your email client provider for further trouble shooting steps. I apologize for any inconvenience this has caused.

  • Bob_U's avatar
    New Contributor
    Well, I have the same issue. My IT people can't figure it out, and Support hasn't been much help. If you can't fix it, let me know so I can look at other options.
  • ILC's avatar
    New Contributor

    But this IS a Cox problem. First of all, it comes and goes. Second, it happens on all devices, even the ones without Outlook. Third, it happens on all sorts of different versions of Outlook, and OS. Fourth, I have other accounts set up in the very same Outlook AND on the very same devices (gmail, and another account that operates on a foreign server, of all things), and THE OTHER ACCOUNTS WORK FLAWLESSLY. But this issue affecting the Cox accounts exclusively periodically rears its ugly head and persists until I complain via this forum and then you do whatever it is you do on your side to fix it. (Phone support has been of no help, unfortunately.)

    It's obviously not just me with this issue. It seems rather prevalent and wide-spread, and we would not be complaining here if this wasn't circumscribed to our Cox accounts. There must be a fix for this.

    Please check the records of what was done for my past complaints, because whatever it was, it worked, at least for a long while.

    Thank you.

  • bryaninphx's avatar
    Valued Contributor

    POP3 Authentication Errors.
    Having same issue with periodically ongoing server authentication errors.  Cox's email Servers are not passing credentials about 50% of the time.  Problem is on all devices and platforms.

    Yes, my server settings are correct.

  • handy2sum's avatar
    New Contributor

    Agree completely with ILC!!  This is a COX issue that comes and goes. Still getting the popup every few minutes.  Once I click OK (without making any changes to any setting) my email sends/receives for a few minutes until the popup comes back.  Its as if the COX server is not recognizing the password until its reminded what it is.  Then it forgets again.  Server seems unable to reconcile password to the account.

  • Neuro2015's avatar
    New Contributor III

    Seriously with that response? This is a Cox issue that's been happening for years...and we get the same canned answers that we've all read for years across hundreds of posts from customers regarding this issue.

    I go through this issue a couple times a year, every year, like clockwork. We all do. This is not a settings or password issue, or else it'd be happening 24/7. Most of us are all following your own support page on what settings our email programs are supposed to have. 

    Furthermore, Cox Webmail isn't even working. I've been trying to go to the login page on the Cox site for hours...and keep getting an error page. See attached screenshot of the error message.


  • akl's avatar
    New Contributor

    I am having the same problem with Outlook.  It seems to have started for me when Cox made the email switch to new server port numbers and SSL encryption.  Definitely a Cox problem that needs to get resolved.

  • Neuro2015,

    I haven't replicated the error you see. Are you still getting the error message when accessing signin page, or is that the message that appears after signing in with any username and password? If this error is happening on all devices, please email us at with your account information and the error.

    If the error no longer appears after clearing cache and cookies and you can sign into, then please verify you can send and receive a test email to yourself there.