This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

unable to access e-mail

For 2 weeks I have been unable to access my Cox e-mail, despite 20 hours of communication with Cox I keep getting a notice that I've been "timed out" thoiught I have not been able to enter. They say they have seen this problem before but nobody can fix it.  I have worked with Customer Support, Copmlete Care, and CustomerEscalation, where they marked my ticket "solved" because they could get into my account, but I can't.  After 3 hours today erasing possible blocks on 3 browsers  (Chrome, Edge, Firefox) Mark at CutomerEscalation suggested I go back to Complete Care.  My suspicion is that the problem is at the Cox site, though they don't want to admit it. 

Parents
No Data
Reply
  • cox can both access the account + send temp password!

    bear in mind the pw needs to be changed on all devices that access cox mail or pinging old pw looks like intrusion!!

Children