Gigablast download speed issue

I recently signed up for the Gigablast plan. I am renting the Panoramic Wifi modem/router from Cox. Hooked it up to the coaxial cable outlet in the wall, and connected via ethernet to my laptop (which has a gigabit ethernet card btw.) Ran speed tests (speedtest.net) several times on different days/hours but the maximum download speed I can get is about 300-350 Mbps. Ran Cox's speedtest, same results. Cox sent out a technician, he unplugged the coaxial cable going into the modem and hooked it up to his meter and got over 1Gbps consistently. He checked all the wires, everything looks good, we did a speedtest again - no change in speeds, still about 300-350 Mbps.

I am using original Cox equipment (modem, coax cable, Cat5E cable - all came in the box with the Panaromic Wifi modem.) I have not connected a separate router. There is only one ethernet connection going from Port1 on the modem to my laptop, no cable in ethernet Port2. I don't understand why I get slower speeds when the device the technician used directly with the coax cable gave 1Gbps speeds consistently. I have tried all the usual things - rebooted the modem, my laptop, checked connections - everything looks good. The tech who came out is very experienced. He said he's never seen anyone actually get 1Gbps in my state of Rhode Island. He said 300-350 Mbps is the maximum I could expect, and that Gigablast is really meant for speed sharing over several devices, not high speeds for one wired device. Is this true?

Thought I'd post this on the forum in case there is a way to achieve 1Gbps downloads (btw uploads are 37Gbps as advertised.) I am considering downgrading to the Preferred 150 or 300 plan otherwise (that's what the technician recommended btw...)

Becky, help me!

Parents
No Data
Reply
  • Yeah if you want decent speeds your best bet is going to go buy a new cable modem you own.. When I got Gigablast upgrade the panoramic modem they supplied wouldn't give anymore then around the same speed you mention at the modem (speedcheck showed similar results when they had a tier 2 tech crew come out it was 900-950Mbps there were getting at the connection outside and they re ran the cabling to the house even and couldn't understand why they couldn't get more then 400-500 on their network analyzer at the modem) amazingly I went to Best Buy and bought my own Docsis 3.1 modem and suddenly yep sure as heck speeds went up significantly where my higher end router could speed check and even during busy times I was getting in the 800Mbps range and at night Id hit 900 or so..So the tech likely was full of it.. Go buy your own modem that listed as supporting gigablast (I agree we shouldn't have to because cox should supply hardware worth something to its customers but ya do whatcha gotta do sometimes). 

Children