This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

How to use Shareplay with this unfortunate ISP

I'm truly at my wits and either COX, I cannot Express my disdain for this company in words. I have not been able to use Shareplay on my PS4 since being graced with this ISP. I have called and talked to multiple COX reps about my issue and none can help me so naturally into to my networking friend and Google for help, and when I say I've tried everything we could come up with, we've tried everything, port forwarding/triggering(got port numbers from sony), DMZ, swapped routers (tried 2 Cox issued modems and then purchased my own modem/router combo by netgear, I can provide model numbers when I get home if it helps) i tried a static IP but i don't think I ever got it to work correctly and I tried bridging my modem to my linksys router and they just successfully exploded the net and I had to set everything to factor and start again, I'm hardwired with CAT6 eilthernet cables, now with my personal modem I AM clocking constantly higher speeds than the issued modem but i still cannot use shareplay, its beyond frustrating, I have PS plus and both my friend and I have speeds WAY over the required. I tried to ask for help on Cox Twitter and they were worst than the phone representatives believe it or not. I did see a post up here of someone having a similar issue 10-11months ago and they resolved it by getting their own modem, I'm curious if it worked for them because it wasn't a modem/router combo or if it was before Cox started blocking ports I assume its cause port 80 is blocked which would explain why my port forwarding and DMZ didn't work, if Cox isn't sending the signal at all,opening the ports wouldn't do anything anyway but Cox will not tell me for sure if that is the reason or not I have no clue I'm just making a guess based off the googling I did. Does anyone know why it's not working? And maybe if I'm lucky a solution?? Or am I just screwed to never be able to host a shareplay in the state of NV since they are the only ISP here with speeds fast enough to even game on in the first place x.x (which ** cause I'd really love to never use Cox again) I can join shareplay's my friends host but can never host one x.x I'm going to pull my hair out with this. Can they really block a whole feature from everyone?! 

Parents Reply Children
No Data