Forum Discussion

socaltransplant's avatar
socaltransplant
New Contributor
4 years ago

"insecure connection" on cox webmail?

this is a new problem for me.  it's locked when i open it, but as soon as i start viewing mail, the symbol comes up for "not secure."  i can type in "https//" and it goes back to the lock symbol, but not for long. 

it happens on my new dell with win10...but it also happens now (never did before) on my bootcamped apple running win7. 

there's only one missing party here....COX!

so i called.  level 1 immediately claimed "not my job."  and booted me to "super tech" or whatever they call it to be able to charge 3/mo extra .  he was borderline rude and his solution was that since i could get a secure connection (for who knows how long) on both edge (which i hate) and ie11...whiich i didn't knoow i had, the problem was solved & the ticket was finished.  i asked if he could feed this issue up the food change and his retort was "no.  i don't work for cox.  i work for super tech.  so i asked if he could put me in touch with someone who could.  he gave me back to a cox level on who, it looked like, sovedthe problem.

but it just won't stay solved. 

the other issue i'm having is that i tried to sign in with a subsidiary account days ago. it wouldn't accept the password & while i've logged in with the primary 15 times since then, every time it tries to use the subsidiary email.  it won't for get the other & remember this one.

any ideas people?

10 Replies

  • @socaltransplant, I am unable to replicate the "not secure" issue from my side with Windows 10. Once you access webmail, the lock symbol should return on the address bar. I recommend deleting browsing history and cache. Make sure to include password and other sign in data. This should help with the website remembering your login information as well. Please be advised that this will cause all websites to forget your login information. -Allan
    • socaltransplant's avatar
      socaltransplant
      New Contributor

      ok, been there.  did that.  it's what every tech i've ever worked with says first...hoping that a miracle will occur.

      it didn't.

  • bearone2's avatar
    bearone2
    Contributor III

    i'm using win10 & just checked cox webmail & it's secure.

    are you logging in to cox webmail or typing httpsXXXXXXXX?

    • socaltransplant's avatar
      socaltransplant
      New Contributor

      currently  my forms link has gone to insecure. i have tried log in lots of ways.  i've gone to "my connection," i've typped "https//..."  myemail.cox.net or idm.east.cox.net". the lock symbol is there when i start.  but if i go into anything it comes back insecure. could it be something in my chrome or windows 10 settings?