Forum Discussion

jcarothers's avatar
jcarothers
New Contributor
4 years ago

EXTREMELY Slow Speeds for 6+ months

Hello,

Since February I have had extremely slow internet speeds and other neighbors have complained. I have had 5 techs come out to troubleshoot the issue and they don't know how to help.

I was paying for Gigablast, and the highest DOWN I could get was 120Mbps, but more often than not I would pull  below 5Mbps with extreme jitter. This is direct in on a powerful desktop PC. I have tried 3 different network cards. 

I have tried 3 different modems, tested speeds on the tap outside my house to rule out wiring or interference, modem signal levels look normal

I have downgraded to 150Mbps and STILL get only ~ 5Mbps during peak.

Techs have said the node I am is highly congested. They have also said it's not the node but some software issues in the back-end. It sounds more like they don't know how to solve the issue and are giving me excuses to move on to the next job - this is becoming increasingly frustrating as I work from home. 

I am reaching out for help before I switch to a different provider, but would really like to stay.

Thanks for any support.

9 Replies

  • Jcarothers,

    Thank you for completing speed tests from the Cox website, as this saves a springboard of information to the Modem. The speed tests saved from today appear to be completed outside of the window we reserve a service appointment. The earliest appointment time-frame is 8-10am, and the latest is 5-7pm. What time-frames are you experiencing the speed loss, and is it always the same or random and how long does it last? If the issue is off and on, then this can make it difficult to diagnose. We absolutely want to help find a solution to the issue, and without a utilization or congestion ticket in your area, we would need to reserve a return visit. Please email us at Cox.Help@cox.com with your address, name, and link to this forum message.

    Dustin
    Cox Support Forum Moderator
    • jcarothers's avatar
      jcarothers
      New Contributor

      Thanks for your reply. I have contacted this email and have been ghosted repeatedly. I will be switching to a better provider. Thanks for scamming me. 

      • LisaH's avatar
        LisaH
        Moderator
        Hi Jcarothers. We don't want to see you go. Please reach out to us on Twitter at @CoxHelp via DM, visit us on Facebook via private message, or email us at cox.help@cox.com. Provide us the name on the account with the complete service address with a link to this thread so we can get started. - Lisa, Cox Support Forums Moderator
  • Zb731's avatar
    Zb731
    New Contributor

    I’ve had the same issue. Tried 3 modems and 2 routers, and the support agent had the nerve to repeat the same line from the playbook “it must be your equipment”. On multiple devices? Very unlikely 

  • Zurq's avatar
    Zurq
    Contributor II

    you can't fix it, and they won't fix it. better option is to just switch.

  • dochereford's avatar
    dochereford
    New Contributor

    Having the same issue here in Goodyear AZ. I had 500gbps service.  Last month customer service talked me into upgrading to one gigabit service to fix my speed issues. Guaranteed me I would not see any more issues. Well my issues have changed a bit. I have a technician come out to the house.  The technician tests everything here at the house with his equipment and he gets one gigabit down. Any of my computers, the fastest I get is about 120 down. I have a combination of MacBooks and the laptops as well as a smart TV. They all share the same response time. It’s not my equipment.  I’m currently sitting at 12 Mb per second. Either they explain themselves or I’m moving on to another service.  Something is going on and they’re not owning up to it. 
     
    my company supplies me with a hotspot from Verizon. I actually get faster response to that lol.

    • J_carothers's avatar
      J_carothers
      New Contributor

      Yep. They are flat out lying about their network congestion to keep us paying full price for .005% of product. It's time to switch.

    • CrystalS's avatar
      CrystalS
      Former Moderator
      Hello

      This appears as if you may need someone to look into your account personally. We would definitely be able to assist you with this. Please reach us on Twitter at @CoxHelp, visit us on Facebook, or email us at cox.help@cox.com. Provide us the name on the account with the complete service address with a link to this thread so we can get started.

      Crystal S. Cox Support Forum Moderator