Forum Discussion

JasonInPhx's avatar
New Contributor II
2 years ago

Do not receive verification or password reset emails using Cox.

It has been frustrating because on several websites where the site was supposed to send me a verification or password reset email, I would never receive the email using my cox email address.  It has happened with and AZ MVD site to name just two.  I spoke to the tech person at the the AZ MVD site and she stated that this has been happening to everyone using a cox email address.  Whenever possible, I switch my email to my gmail email address and no problem.  Apparently this has been happening for some time with Cox.  Can anyone tell me why this is happening and what Cox is doing, if anything, to rectify the situation.  (And, no, the emails are NOT going in the spam folder, they are lost in space.)

5 Replies

Replies have been turned off for this discussion
  • CurtB's avatar
    Valued Contributor III

    TiffanyR's  #8a suggestion to deliver to Spam folder probably works too, but I know this does.

    Settings icon > Settings > Inbox > Spam settings > No Spam filtering

    Create the following Filter Rule:

    Settings icon > Settings > Inbox > Filter Rules > Add new rule

    Add condition: From      Contains <sender displayed name> or <sender email address>

    You can include multiple "Contains" entries to process this rule for multiple senders.

    Add action:                       Keep

    Put that rule first.  If the email isn't blocked before getting to Webmail, it will go to your Inbox.

  • Hello JasonInPhx,

    I am sorry to hear that you are having trouble with receiving emails with verification or password resets. There is nothing that I am aware of that is causing this issue. I just tested it with my email address and was able to receive my password reset link. There are some settings that you can check to ensure that the emails are not being blocked or redirected.

    1. Log in to Webmail at
    2. Click on Settings (gear icon) in the top right.
    3. Select Settings.
    4. Click the arrow next to Inbox.
    5. Select Auto Forward.
    a. Ensure Auto Forward is not enabled.
    6. Select Filter Rules.
    a. Delete all filter rules or check each rule to make sure they are not filtering out emails you wish to receive.
    7. Select Blocked Senders.
    a. Delete all email addresses or domains or check each listing to ensure you are not blocking any senders you wish to receive from. A domain would block all emails from that domain.
    8. Select Spam Settings.
    a. Change the Spam Setting to Automatically deliver to Spam folder to ensure that you are receiving all emails.

    Please let us know the results.

    Tiffany R.
    Cox Support Forum Moderator
    • TBeth's avatar
      New Contributor

      Tried all of these, and I still get no email password resets or code verification emails. Very frustrating. I’ve spent hours trying to fix it. 

  • WiderMouthOpen's avatar
    Esteemed Contributor

    Why can't you just use your Gmail account for verification? It works and is more secure.

    • Darkatt's avatar
      Valued Contributor III

      Turning off the "delete spam" option normally fixes it.