Forum Discussion

I_am_Richard's avatar
New Contributor III
4 years ago

Cox blocking content from AMC Theatres

A few weeks ago I noticed that the AMC Theatres website was not functioning correctly.  Specifically, a lot of the content on the site just does not appear.  For example, there is a section on the main page that says "Movies at AMC", and normally there would be a grid of movie posters listed.  However, nothing's just blank.  As another example, there's a banner on the main page that scrolls through various featured items they are hilighting (like new movies), and if you click on one of the banners it will take you to the relevant page...only on my system the page doesn't contain any of the expected content, but instead only contains the basic web page template (e.g., I can see all the normal navigation links, etc., but nothing relevant to the banner I clicked).  Additionally, when I try to login to my AMC account, the website acts like its submitting my login information but it doesn't seem to actually do anything.  Firefox, Chrome, and Edge all have the exact same behavior.  I see the same issue when I browse the AMC Theatres website in Safari on my iPhone.  Relatedly, whenever I tried to use the AMC Theatres app on my iPhone, every function within the app results in an error message stating "Network Issue Occurred.  Tap to retry."

So naturally I assumed that the issue was with AMC's website.  That was, until I disabled the wifi on my phone (thereby switching the phone to cellular data) and discovered that all of a sudden the AMC app works again, as does their website.  As soon as I switch the phone back to wifi, it all stops working again.  So then I thought maybe there is a problem with my router.  So I bypassed the router (i.e., I ran the ethernet cable from my modem directly to my PC.)  That did not fix the problem.  So then I switched the wiring back, and established a VPN connection to my work (Cox Business, with all traffic routed through the work network), and all of a sudden the website started working on my home PC.  As soon as I disable the VPN connection, it went back to not working again.

At this point it appears that Cox is blocking access to some--but not all--of AMC Theatre's content, and apparently only on home connections, not business connections.  Can someone please fix this?

39 Replies

Replies have been turned off for this discussion