Forum Discussion

broadcastguy's avatar
broadcastguy
New Contributor
4 years ago

Can't connect to certain domains and roku won't connect to certain streaming services. Santa Barbara Service Area.

I'm in the Santa Barbara California Cox service area.  For about a week and a half I have had difficulty connecting to certain domains thru my browser.  This includes latimes.com and even cox.com.   My roku won't connect to certain streaming services or if it does it doesn't load icons.  Sometimes it won't play content.  In the browser i get disconnect errors.

If I use my phone data plan I can connect to all of this stuff without a problem.

I have called cox about 8 times with no help from them.  They will not escalate the problem or do they seem to know about the problem. 

In looking at this forum I have found others who have experienced this problem such as in Virginia Beach, VA last year.

Anyone else seen this problem or know how I can escalate it.

7 Replies

  • Bruce's avatar
    Bruce
    Honored Contributor III

    What you could do to escalate is send an email to cox.help@cox.com with the following:
     - URL of This Post
     - Full Name
     - Complete Address

    It reads likes you're only reaching cached pages and when you select content, your request fails.

    DNS servers...?

    Ipconfig /all

      • JonathanJ's avatar
        JonathanJ
        Former Moderator
        @Broadcastguy

        We will respond to the email once received it we haven't already.


        Jonathan J
        Cox Moderator
  • BayouBoy's avatar
    BayouBoy
    New Contributor

    certainly try contacting roku support also and detail and/or send pictures. I know for a fact they work on this stuff during beta testing.

  • BayouBoy's avatar
    BayouBoy
    New Contributor

    send info with pictures to roku support. I know for fact from my own issue they handle this stuff during their beta tests.

    • Bruce's avatar
      Bruce
      Honored Contributor III

      Problem is happening on different platforms (computer & Roku) and only on Cox connections.

  • Thanks for every ones input.  I took the router out of the equation and the problem went away.  My router is 10 years old.  I bought a new TP-Link AX50 AX3000 and it all works like a charm.  Not sure why if it was a router problem why only certain websites and or roku channels would not work, instead of everything being messed up. 

    My only uneducated guess is that it had to do with distance and the amount of time that it took for a network response.  Maybe closer things such as the LA Times and Cox caused the problem to be worsened.