This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Popup password box (outlook)

Why am I asked over and over to put in my password in email (outlook---pop account) even though I keep putting a check mark in 'remember my password' box?

  • When you say "asked to put in password", what exactly are you seeing on the screen?  Many of us have been getting a box that says "unable to connect to server; the server doesn't recognize your password. Please enter your password".  That message box is usually associated with problems with the system-wide email.... not just your computer.

    And when you say "over and over", do you have to enter the password before sending every single email?  Or does it just appear once each day when you turn on your computer and check for email?

  • I'm familar with the msg. you are talking about;I tried switching from an IMAP account to a Pop account and have not seen that 'unable to connect' message since I switched; mine is a litthle box that pops up that ask for my password. After I put my password in, my emails will come through. No I don't have to enter on every email, just sometimes.

  • Hi Don1958, 

    Please check to make sure the username does not include @cox.net and you may also need to try to change the password at www.cox.com/password . Once you have changed it at our webpage, then change it on each mail client to match the password. Let us know the results. 

  • This problem is driving me crazy.  The popup box comes up asking me for my email password even when I'm not sending emails.  I can be typing a letter in Word (or this reply) and the box will pop up and my typing will show in the password box instead of my letter.  I've tried rebooting the computer and the problem went away for about 20 minutes.  My account is already set up as a POP account so no help there.  Doesn't anyone else other than the two of us have this problem?  I'm in Gilbert Arizona.

  • Rhondah, i got the "POP server rejected the password...." box this morning at 11am Phoenix time.  I was able to send email; not receive.  I was able to get the mail to work by hitting the GET MAIL button.  This does not always work.