This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Cox should change email posture and support users

I have an acute problem and a chronic one.  The acute problem is that for some reason the Cox outgoing email server doesn't like my ip address.  We recently upgraded from satellite internet service to fiber at my parent's home and the result was great speed but while I could receive my email in Outlook Cox wasn'allowing me to send.  Nothing changed on my phone or computer except the internet service provider.  If I go to the village and connect to my cell phone provider, emails wiill then send, but fail again when I return to my parent's home, where I often visit.  How can I get Cox to accept my outgoing mail on the SMTP server? 

The chronic problem, and I suspect the root cause of the acute one, is that Cox has turned their back on their most loyal customers and decimated their support for email.  They don't want to be in that business but would prefer to have others bear those costs.  But many of us long-time customers have a significant amount of time invested in these email accounts and don't want to switch.  Does Cox care?  I for one can assure them that if this acute problem isn't resolved and I have to bite the bullet and move to another email platform, I will be taking my entire account away from them--internet, phone and cable TV-- which is only a couple of hundred dollars a month but I'm sure the folks over at Full Channel / i3 Broadband would be happy to have my business.

Parents
No Data
Reply
  • Hello FredRock,

    I am sorry to hear that you are experiencing trouble sending emails from your parent's house. Most Cox customers are able to send emails outside of their homes. Are you using Cox's outgoing mail servers?

    Server name: smtp.cox.net
    Enable SMTP authentication for outgoing email, and then enter your Cox Email address and password
    Enter one of the following port numbers based on the encryption type
    If the encryption type is SSL or SSL/TLS, then use 465
    If the encryption type is TLS or if your device doesn't support encryption, then use 587

    Have you tried using the outgoing mail settings for your parent's ISP? If not, are you able to try?

    Tiffany R.
    Cox Support Forum Moderator

Children
No Data