Forum Discussion

rayme's avatar
rayme
New Contributor
9 months ago

freeform issue

Freeform says that cox does not have freeform so I cannot access freeform via my internet browser or roku. This is a new problem. All was fine last week.

Error msg:
You have not been signed in since it appears your TV subscription does not include access to the following channel(s):
Freeform
If you believe you have received this message in error, please contact your TV provider.

8 Replies

  • Hi Rayme, I tested this today, and I'm not able to use my Cox credentials to access Freeform video content, either. So that we can investigate this further, please email my team at Cox.Help@cox.com. We'll get to the bottom of this for you! -Becky, Cox Support Forums Moderator
      • Becky's avatar
        Becky
        Moderator
        Sorry I missed that post, WMO. It looks like Danny answered it for me. -Becky, Cox Support Forums Moderator
  • Hi Everyone, we believe the issue with Freeform has been resolved. Please try accessing Freeform content again today. If you still get an error, clear the cache and cookies on your device and try again. I'm now able to log in using my Cox credentials and play video content. Thank you for your patience as we worked to resolve this for you! -Becky, Cox Support Forums Moderator

    • FantastikMrFox's avatar
      FantastikMrFox
      New Contributor

      Hi. I never got the chance to respond because I was on vacation but the issue was resolved. Thank you for your help.

  • WiderMouthOpen's avatar
    WiderMouthOpen
    Esteemed Contributor

    I tried to check if Cox is a participating provider but their support page links to something behind a corporate Disney login. My guess is they used a internal link since Freeform is a Disney owned channel. I suggest contacting Freeform and asking them if you should have online access. Maybe they charge extra like ESPN does for some content. You can also email Cox at  cox.help@cox.com and see if there are any known issues. Good luck!

    • WiderMouthOpen's avatar
      WiderMouthOpen
      Esteemed Contributor

      I just tried the login link for connecting your Cox account on the Freeform page and got: "503 Service Temporarily Unavailable" so I think something is broken/down.