Forum Discussion

Nadafan's avatar
Nadafan
New Contributor
6 years ago

Bad equipment - no credit

 Last August started having issues with contour box resetting every 10 - 15 minutes. Had cox out 4 times about it. No credit given for all the time we had no service. Made a payment online as had done in past but got notice from Cox it didn't go thru, checked bank cause I knew the money was there, bank said no request for payment received. Thinking I may have erred in entering info, I resubmitted pmt. Same thing, again bank said nothing came from Cox. Soooooo, after not giving credit for 3 months of little to no service and failing to submit payment info to bank. I let my cable be turned off. I did get credit for 1 week, for yhe wait between the last time I called about no service and time tech came out and FINALLY replaced the faulty box. Was told to contact collections, who told me to contact billing two attempts to transfer, I was hung up on. I called support and was told since account is off they cannot see Tech notes and will not give credit.  Ummm.....how is it the rep in store could see the 4 service calls approx every 2 weeks. Anyway, same old Cox, the ones that continued to charge me for a 2nd box months after I had turned it in.  NEVER AGAIN and I won't be recommending them.  But shout out to Nestor A at my local store, he was helpful and courteous!

1 Reply

  • Hi Nadafan,

    Cox provides the Support Forums as a service to its customers and non-customers to help them obtain support, exchange ideas and get information relating to Cox products and services. Billing and account questions that require the sharing of personal information aren't suited for a public forum. For further assistance, please email us at cox.help@cox.com with this post, your full name, and complete address.

    Maria L.
    Cox Support Forum Moderator