Forum Discussion

beefig520's avatar
beefig520
New Contributor
4 years ago

Upgraded to Gigablast and got worse speeds

So I got the modem from Cox today (TECHNICOLOR: CGM4141 D3.1 OR PON GATEWAY) and set it up. 

Everything went fine except it took a couple attempts to finally get the modem activated. The issue I'm facing now is I am getting comparable or even worse results than I was getting from the lower Ultimate Classic package I was on before.

I tried all the troubleshooting that I could do (below)

  • Powered off the modem a few times
  • Connected directly to my computer via Ethernet
  • Reset the modem to factory defaults
  • Tried a different Ethernet cord
  • Restarted my devices
  • Contacted support via chat

A quick run through of chat support

  • Had me unplug the modem a few times
  • They reset the modem remotely
  • Had me remove the attenuator from the coax line
  • I think they re-did the order as well

Nothing helped and the support person said  "somethings are out of Cox's control" which is true, but I do not believe it to be the case in this situation, considering this is a Cox modem, and a superior package, while my own modem on Ultimate Classic outperformed this combo.

They also said I do appear to be on the Gigablast package already so it isn't a problem of not being activated yet. Though I do find it weird that the service is only listed as "high speed internet" on my account page and I still get prompted to upgrade to Gigablast, which shows me that my current plan costs me $0.00. I'll attach an image.

So what do I do now? 

2 Replies

  • beefig520's avatar
    beefig520
    New Contributor

    Okay you can ignore this. Another chat person has fixed my problems it seems, something went wrong with the order. 

  • Coxisgarbage's avatar
    Coxisgarbage
    New Contributor III

    File a complaint with the FCC, if enough people do this we can hopefully get resolution.