Forum Discussion

SHong's avatar
New Contributor
4 years ago

two different MB7420 modems keep rebooting during activation

Recently, I've tried to activate a MB7420 with Cox but this first MB7420 kept rebooting after activation. After 5 - 6 times rebooting, we gave up and returned to the old TP-link modem which works fine. I've got the second MB7420 modem and tried to activate with Cox and it failed. It keeps rebooting during activation. The error log files in both MB7420 show rebooting happens just after INIT SOFTWARE log is recorded. I guess it was trying to update firmware by COX but those modems keep rebooting. Two different modems of the same model show the exact same problem. I wonder if Cox pushes an incompatible firmware to these MB7420 modems. Called Cox but no resolution. Can this be fixed?

2 Replies

  • @SHong, We can take a closer look for you. Please send us an email with your full name, address, and a brief description of this concern to -Allan, Cox Support Forums Moderator.
  • bearone2's avatar
    Contributor III

    maybe both modems have the same problem and it's not a cox issue.