Forum Discussion

Jaeger's avatar
Jaeger
Contributor
10 months ago
Solved

Port Forwarding

Just out of curiosity, does Cox currently allow Port Forwarding or is it blocked by the ISP? I have opened a number of ports through my third party router and Windows Firewall as necessary to temporarily host a dedicated server for some friends to play a game. It is not the first time I have done this either. Years ago, I would be able to open these ports and go to a website such as canyouseeme.org to verify the ports are open. However, now whenever I check these ports I am being told that they are still closed and my friends are unable to see or connect to the server when it is up.

I've tried updating my router's firmware, resetting it to factory defaults, power cycling both the router and modem, etc. I cannot for the life of me figure out why these ports are still showing as closed when the router indicates they are opened and that Port Forwarding is turned on.

  • +1 for modem and router you have. Cox does not block port forwarding. See thread here.

    ::edit:: Do you still have the MB8600? If so, try bypassing the router and connect direct to the MB8600 with ethernet and the power cycle the MB8600 to renew DHCP. See if the ports are open then. That will see if your firewall on your OS is open.

17 Replies

Replies have been turned off for this discussion
  • My first question for you would be what are you using for a modem?  Is it truly just a modem or are you using a gateway type device that also features a built-in router?  If the latter, there's more steps required to accomplish what you're trying to do.

    • Jaeger's avatar
      Jaeger
      Contributor

       I'm presently using a Motorola Surfboard MB8600 for a modem and an ASUS AX-3000 for a router. Two separate devices that used to do what I'm having issues with just fine. Please see the reply I gave to WiderMouthOpen below for extra details though!

  • WiderMouthOpen's avatar
    WiderMouthOpen
    Esteemed Contributor

    +1 for modem and router you have. Cox does not block port forwarding. See thread here.

    ::edit:: Do you still have the MB8600? If so, try bypassing the router and connect direct to the MB8600 with ethernet and the power cycle the MB8600 to renew DHCP. See if the ports are open then. That will see if your firewall on your OS is open.

    • Jaeger's avatar
      Jaeger
      Contributor

      Glad to see you're still here providing support. You've helped me immensely in the past! I do indeed still have the MB8600 and I currently have an ASUS AX-3000 for a router at this address. It's strange because this used to function perfectly fine with no issues at all. When I opened ports for whatever reason and checked them, they came back as open. For what it's worth I did also try disabling the router and windows firewalls and even temporarily using the DMZ function within the router to see if that made any difference. Even with all of that the ports were showing as closed. I did also verify my public IP and WAN IP were the same so I suppose I can assume this isn't a CGNAT issue.

      In any case I did as you suggested and connected straight to the modem, bypassing my router entirely. The ports are still coming back as closed via various port checking websites. I tried again after totally disabling Windows Firewall (private, Public, and Domain) and even then they still show up as closed.

      Some potentially relevant information: I recently moved to Ohio and utilize Spectrum internet there. I continue to pay for a utilize a Cox account for my parents who are the ones using the MB8600 here in Virginia. Back in Ohio, I was successfully Port Forwarding with the same make and model of router (but not the same EXACT router) and the same laptop I am using now during this visit. Therefor I am at the very least sure my laptop and firewall are not to blame for this issue.

      • WiderMouthOpen's avatar
        WiderMouthOpen
        Esteemed Contributor
        bypassing my router entirely. The ports are still coming back as closed via various port checking websites

        If that is the case, then you can rule out the router, which is a good thing. Try listing the ports on your computer by Windows key + R > CMD > Netstat -ano > Left click to select the data and enter to copy it. Then paste it into wordpad and CTRL+F to find the port. 

        Also, do you have any A/V other then Defender? If so, try disabling/uninstalling it.

    • WiderMouthOpen's avatar
      WiderMouthOpen
      Esteemed Contributor

      Everyone breaks that rule, and Cox doesn't(AFAIK) enforce it. They would have to disconnect every kid that plays a game or streams a phone call. The spirit behind that rule is to stop people from running web servers and things that saturate the upload bandwidth. Port forwarding is allowed, even on the Cox gateway. If they wanted to stop servers they would disable port forwarding on the gateways. However, they are making port forwarding harder to do by storing the settings in the cloud, so you have a point. So they probably don't like it but they do allow it.