Forum Discussion

jc00's avatar
New Contributor
5 years ago

Not getting Gigablast speeds

I recently bought the Netgear CM1000 modem and the Netgear AC1750 R6400v2 router. I just upgraded to Cox Gigablast speeds about a week ago. The speeds I'm suppose to be getting are around 940 Mbps. When I run speed test from my laptop and desktop my speeds only top off at around 550 to 600 Mbps. That's from modem to router and being hardwired to the desktop or laptop.

I have tried testing straight from the modem to the laptop or desktop. Same results, 550 to 600 Mbps. I've changed from CAT 5e to 6. No changes. I've power cycled my modem with no luck. Reset my router, no luck.

I ran a speed test via Wifi on my Galaxy S10 and I got roughly the same speeds.

Any solutions or tips?

5 Replies

  • PGriffin's avatar
    New Contributor III

    You are lucky, that's a lot faster than I've been getting!

    Wired connection with a Cox modem, my speeds top out at 350 Mbps.

    Wifi is much worse, like 70 Mbps over a 5Ghz connection sitting right next to the modem.

  • @Jc00. The modem is reporting some poor signals at this time. Are there any splitters or signal amps on the cable line going to the modem? -Allan, Cox Support Forums Moderator
    • jc00's avatar
      New Contributor

      I wouldn't happen to know. Where could I check and how do I get this fixed?

  • jc00's avatar
    New Contributor


    Support sent out a tech today, to the house to take a look at the issue. He immediately saw I was having signal loss. He took care of some bad wiring. That basically did the job. I am now getting full speeds.