Forum Discussion

Dvhr's avatar
Dvhr
New Contributor
7 months ago

Multiple spam phishing email

For almost two weeks I have been inundated by spam phishing email telling me my mcaffee account has expired, my norton has expired, my prime account as expired, etc. They all look similar. What is frustrating is that I get the same messages numerous times. The "from" gets changed probably to get around spam filters but the same messages keep coming. Sometimes 10 or more a day. Is there anything Cox can do to stop these emails?

4 Replies

Replies have been turned off for this discussion
  • LarryK18's avatar
    LarryK18
    New Contributor

    Apparently Cox removed the Spam Filtering from email. The tech called it a "new feature" that they've been getting many complaints about (hmm, I wonder why). They are "working on it". 

  • CurtB's avatar
    CurtB
    Valued Contributor III

    Are these emails going to the Spam folder?  If not, Filter Rules can be created to block them that are based on subject, sender name, etc. rather than email address.

    • Dvhr's avatar
      Dvhr
      New Contributor

      Some go to trash, some to Inbox. I have created filters which work briefly, then the spammer sends the email again having changed the subject, sender e-mail, etc. Ordinarily, I get very little spam and it seldom gets to the Inbox. This spammer is much more persistent. I really don't understand why the spammer keeps sending so many copies of the same email phishing schemes. If I'm not falling for the scam, why keep trying?

      • CurtB's avatar
        CurtB
        Valued Contributor III

        For Webmail not going to the Spam folder, How to: Prevent Webmail Spam will provide detailed instructions for how to block Webmail spam.

        Note: these instructions were created for the previous version of Webmail.  Ignore the First paragraph that refers to "Turn off Webmail spam filtering".

        As far as I know, Filter Rules are the same but the settings path has changed.

        Settings gear  > All settings > Inbox > Filter Rules > Add new rule