Forum Discussion

TynMahn's avatar
TynMahn
New Contributor
6 months ago

Fancy COX Router/Modem refusing Thermostat Connection

So, I have these thermostats that connect to my wifi.  Up until yesterday night sometime, they were connected just fine.  Something changed.  Now, the router will not let them connect.  I restarted both the thermostats, and the router.  I deleted the thermostats from the router. then tried to reconnect them.

I was able to get the thermostats to connect to another router just fine.



--Related rant that COX should hear but, they make it all but impossible to reach out to provide feedback
So, I have the cox panaramic router thing and for some reason, it started refusing connection from my thermostats yesterday.  I tried to call tech support about this but, because I had an outage near me (WHICH WAS NOT AFFECTING ME IN ANY WAY!!), I was not allowed to talk to anybody in tech support.

My issue had nothing to do with internet service.  My issue was I needed help with their stupid router but, I couldn't get it because COX ....... This is just one of the myriad reasons why, if I ever get the chance, I will dump COX fast as I can...I hate this company so much.

2 Replies

  • WiderMouthOpen's avatar
    WiderMouthOpen
    Esteemed Contributor

    If you have your own router, I suggest getting your own modem. Do you have Cox phone service by any chance? If so, you can get a free phone modem that works for internet too. If so, I suggest buying either the Arris SB8200 or S33.

    As for getting ahold of Cox, sounds like your problem is beyond basic support and they probably would have tried to upsell you to Cox Complete Care, so there is a silver lining here.

  • DRVEGAS's avatar
    DRVEGAS
    Valued Contributor

    Are they Nest thermostats?  I sometimes have the same problem with my Nest thermostat and I'm able to get it connected again just by rebooting the router and my phone and the thermostat as well so try that.  I'm using the panoramic phone/modem router here.