Forum Discussion

SueJohnson's avatar
SueJohnson
New Contributor
2 months ago

Deleted messages stay in webmail

I am using Cox in the northern Virginia area. When I delete a message in webmail it still appears in my inbox. I have to go to another folder - spam or trash and then when I return to the inbox it is gone. When I sign into the webmail, it behaves OK for a few deletes but then reverts to the above behavior, Even if I delete an email in spam It doesn't disappear until I go to another folder. I have used chrome and Firefox. Same behavior. This is on my laptop. I had Windows 10 and decided to buy another laptop with Windows 11 hoping the issue was with my laptop. Nope. Same behavior.  Any ideas? 

11 Replies

  • CurtB's avatar
    CurtB
    Valued Contributor III

    I don't know that it's related, but in the interest of research, do you 'Sign out' when you leave Webmail or just close the browser tab?  If you don't mind. would you do the following and tell us what you see?

    Settings > All settings > Security

    Do you see more than one session listed ("Cox Email... Sign out")?  If you do, click "Sign out from all devices" and click "Sign out" to leave Webmail.  Open Webmail again and see if you still have the issue with deleting email.  Either way, your issue will go away within the next 5 months when Webmail is converted to Yahoo Mail.

    • SueJohnson's avatar
      SueJohnson
      New Contributor

      I see: Your devices - then Cox Email, Firefox 121 on Windows.

      I don't see more than one session. 

      I don't sign out. I just accidentally forget I am still on that tab when I search for something else on Firefox. Or when I restart the computer for some reason. 

      • CurtB's avatar
        CurtB
        Valued Contributor III

        It's interesting that you only see one device listed when you don't Sign out when leaving Webmail.  If I just closed the browser, I would accumulate sessions until I clicked "Sign out from all devices".  I'm not sure why it happens or if it matters.  It must be a browser thing.  (Apparently, Webmail thinks I'm using Chrome when I'm actually using Edge).  But it doesn't sound like that's related to your deleting email issue.  Thanks for checking.   

  • WiderMouthOpen's avatar
    WiderMouthOpen
    Esteemed Contributor

    You bought another laptop just to test a webmail problem? Ouch. Hopefully you were ready to upgrade anyway.

    Do you have another Cox email account? If so, does that do it too? The only work around I can think of using a email client like Outlook or Thunderbird. It could have something to do with the transition to Yahoo email. Have you gotten the email from Cox about it yet?

    • SueJohnson's avatar
      SueJohnson
      New Contributor

      No I also had another problem which bothered me much more which thankfully did go away. 

      No I don't have another email account. I use another email client, OEclassic,  but that that is not for webmail which I access via the internet.

      No I haven't gotten anything about the transition to Yahoo but this has been going on for many months. 

      • Darkatt's avatar
        Darkatt
        Valued Contributor III

        Try refreshing the page. For some reason the page in your browser isn't refreshing and that's why the message still shows after deleting.