Forum Discussion

chevylover's avatar
New Contributor

Being put on hold or not not being transferred to the right dept.

COX is starting to really p-ss me off. Getting an "Internal error" message when trying to log into web mail,using Firefox. Called about this 2 weeks ago,and was given a temp password & it worked fine. for a day. Reset Firefox again this morning, and it worked fine just the tech support answered for 5 minutes. Called again & was transferred to "Complete Care". Didn't ask for it. HAD TO BE  sent back to the beginning instead of being transferred to Tier 2 support. WHY? This is a F'd up system. Waited on hold for Tier 1 for 20 minutes to answer, so I could be transferred to Tier2, where I'd probably be on hold there for another 10-20 minutes. Why can't callers be put into a Que and, called back when a support person is available? 

1 Reply

  • Hi Chevylover, I'm sorry to hear about your customer experience thus far. Have you tried any other browsers, Chrome, or Microsoft Edge? Is your browser upt to date? Is that the extent of the error message, "internal error" or is there more information? Have you tried to access your Cox email from another device or while you off your home network?

    Thank you,

    Mike J.
    Cox Support Forums Moderator