Forum Discussion

jfleming116's avatar
jfleming116
New Contributor
8 months ago

cannot configure my cox email with outlook

Hello, i recently did a password change.  ever since my email address in outlook says "please check the outgoing (SMTP) server settings and try again.

 

my settings for smtp are

smtp.cox.net  port = 465  and i tried 587

encryption method = ssl/tls

 

i tried a reboot of pc, no go.

 

it always asks for the password for smtp.cox.net, and i enter the new password, and it doesn't work.

 

almost like outlook has retained or is using old password.

 

Cox tech support says it is a windows/outlook issue.

 

Can someone help ?

 

 

 

 

 

25 Replies

Replies have been turned off for this discussion
  • Darkatt's avatar
    Darkatt
    Honored Contributor

    It's actually a bug in outlook, it's not updating the configuration file properly. If your using IMAP, go ahead and simply delete the email account from outlook, close outlook, reboot the computer, open outlook, and add the account back as new, and it should work after that. 

    • jfleming116's avatar
      jfleming116
      New Contributor

      Yes i can, when i create a new account in outlook it always asks for the password for the outgoing server, which i enter(the new password), its like there's an outlook config file that needs clearing or resetting ?

       

      • ChrisJ2's avatar
        ChrisJ2
        Moderator

        Hi, there. I might suggest checking the username field for your SMTP server settings. If your username has the suffix (@cox.net), remove it and just use t he email prefix. Let me know if this helps. 

    • WiderMouthOpen's avatar
      WiderMouthOpen
      Esteemed Contributor

      Say's who or since when? According to here it is "free forever" but allows for donation to "make it better". See here for the FAQ. I just downloaded and installed it on my PC a couple months ago for my Gmail account.

  • i managed to get a free download of Thunderbird, tried it and get message 

    "unable to login to server, probably wrong configuration, username or password"

     

    so is this a cox issue, certainly appears so ?

      • jfleming116's avatar
        jfleming116
        New Contributor

        Yes, continually fails, asking for smtp password.  I'm beyond frustrated with tech support. 

        Hopefully i can get someone who cares and can help.