Forum Discussion

Marcust999's avatar
Marcust999
New Contributor
4 years ago

Audio Sync Issues w/ Sonos Playbar

I have a new Samsung UHD Series 7 TV hooked up to a small Cox box (have Gigablast) via HDMI. The TV audio is connected via optical cable to the Sonos Playbar. Whenever I watch live TV the audio is out of sync by half a second or so. When I watch something off the internet (Netflix/Amazon/Hulu etc..) there is no syncing issues at all. I toggled the audio back to use the TV audio and it's fine. Its only when I'm routing it to the Sonos does it go out of sync after a min.

Tried resetting the box, and tv..no change..

Any ideas?

5 Replies

Replies have been turned off for this discussion
  • Bruce's avatar
    Bruce
    Honored Contributor III

    What are the audio options of your "small Cox box?"  For example, Contour button > Settings (gear icon) > Device Settings > Audio > HDMI Audio Output...and you'll notice 3 settings:  Stereo, Auto Detect and Expert Mode.

    Auto Detect allows Contour to negotiate the audio format with your TV.  Expert disables negotiation and Contour just transmits the raw audio data to your TV to process, decode and separate.  You may need to toggle between the 2.  i would assume Expert mode.

    Doesn't the Sonos have a Lip Sync control feature?

    • Marcust999's avatar
      Marcust999
      New Contributor

      Hey Bruce - Thanks for the reply.

      Yes my box has those 3 settings. Using the "stereo" setting seems to last the longest - a few min - but then the audio gets out of sync.

      There is no lip sync control. From Googling further, this appears to be somewhat of a common issue between Samsung TV"s and the Sonos Playbar...I'll keep digging as I doubt Cox support can do much, if anything.

      • Bruce's avatar
        Bruce
        Honored Contributor III

        Okay...now check the audio setting on your TV.  You don't want either Contour or your TV to process any audio data.  Just feed the raw audio to your Sonos.