Forum Discussion

AZTreasach's avatar
AZTreasach
New Contributor
4 years ago

Why are my good emails sent to Spam and Spam sent to me in WebMail

All the emails I send to myself or my wife is sent directly to Cox Webmail Spam folder. Also seems anything that Apple send me also goes to Spam except App or iTune receipts. I know you can't make a filter rule after the fact and sure it troublesome to go to Cox Webmail to move all the Spam to your inbox.

3 Replies

  • ChesapeakeChris's avatar
    ChesapeakeChris
    New Contributor III

    Filters, RBL's, etc. like Spam Assassin and the like they use.

    If you can, always move "wanted" messages from your spam folder to your inbox; this will help "whitelist" the sending address.

    For "unwanted" messages, select them and then click the spam button. This will help to "blacklist" the sending address domains. If the message appears legit, but you don't want them anymore, then click their "unsubscribe" link. The message may need to be transferred to your inbox for the link to work. Give it time and your mailbox will begin to "remember".

    Hope that helps...

  • SharonL's avatar
    SharonL
    Former Moderator
    Hello,

    Thank you for reaching out to the Social Media Team. Cox flags suspicious email as spam to help prevent it from reaching your Inbox. I would recommend viewing www.cox.com/.../forwarding-spam-phishing-or-virus-email-as-an-attachment.html and www.cox.com/.../cox-email-settings.html.

    If you need further assistance you can reach us on Twitter at @CoxHelp, visit us on Facebook, or email us at cox.help@cox.com. Provide us the name on the account with the complete service address with a link to this thread so we can get started.

    Sharon
    Cox Support Forum Moderator
  • yak's avatar
    yak
    Contributor III

    No one has posted a fix for this in the last year.  You are not alone.  I finally changed the Settings so all of my mail comes to my Inbox.  I delete the Spam from there.