Forum Discussion

Captain_Motorbo's avatar
Captain_Motorbo
New Contributor
4 years ago

Webmail login on Cox website problems

For the past year or more it always takes the login page a long time to load when I go to webmail on the cox website.  When the login box finally loads, it takes a long time to process the password entered and load the e-mail.  It usually loads the e-mail but occasionally it does not.  FOR THE LAST TWO DAYS THE LOGIN PAGE HAS WORKED GREAT!  The user name and password box was slightly larger again and worked smooth and fast like every other website.  BUT IT DIDN'T LAST- TODAY IT'S BACK TO THE SAME OLD **.  I WAS NOT ABLE TO LOGIN AGAIN.  It is also back to the smaller login box  This is the only website or login page that ever gives me problems, and ironically it's for the company that I pay high prices for fast internet service.

3 Replies

  • ChrisL's avatar
    ChrisL
    Former Moderator
    I would firs suggest trying to clear the browser's cache/history and see if that helps. I suspect you saw improvement when we changed the sign in page because it was a new page and not cached but it sounds like the browser has returned to displaying the older content for some unknown reason.

    -Chris
    • deframj's avatar
      deframj
      New Contributor

      Hi Chris,

      I've been having the same exact problem as "Captain Motorboat" so no need in describing it. I'm using Google Chrome Version 80.0.3987.122 (Official Build) (64-bit) Incognito - so no cache or history issues involved. The email login worked flawlessly until end of February 2020, except for 1 or 2 days as noted above when it looked like Cox changed the login screen to a larger, easier to read size. I though Cox had fixed the problem. Then it came back. I thought maybe Cox was in the process of changing something behind the scenes, and therefor the problem.

      deframj

      • bearone2's avatar
        bearone2
        Contributor III

        i've moved from chrome to firefox because i was tired of slow or "not responding" in title bar with chrome.