Forum Discussion

eaternet's avatar
New Contributor
4 years ago

Unusably Slow Ethernet Speed from Panoramic Gateway with Gigablast


I just finished installing Gigblast wifi today, and my wireless internet works fine.

However, when trying to connect the included ethernet cable to my laptop, my laptop says it connects successfully with internet access, but it is so slow that I can not load any pages. I have tried many possible fixes, such as flushing my DNS cache, re-installing my ethernet driver on my computer, restarting the gateway, and disabling my firewall, but nothing has worked so far. Windows network status says that I am connected to the internet.

For a full list of things I've tried (probably not exhaustive either)...

  • Restarting computer
  • Restarting/rebooting gateway
  • Setting TCP/IPv4 properties to automatically obtain IP/DNS server
  • ipconfig /flushdns
  • ipconfig /release
  • ipconfig /renew
  • netsh winsock reset
  • Disable Windows firewall
  • Disable firewall in Cox gateway settings
  • LAN Ethernet link status is active in Cox gateway settings
  • Try different ethernet cables
  • Try both ethernet ports
  • Disabling/re-enabling ethernet network adapter
  • Check/uncheck TCP/IPv6 in ethernet properties
  • Disconnect from wireless network
  • Ran TCP Optimizer
  • Checked hosts file (nothing in there)
  • Get-NetAdapter in PowerShell shows link speed of 1 Gbps
  • Disable/enable "Automatically detect settings" in Windows proxy settings
  • Windows network reset
  • Clear cache in web browser
  • Tried multiple browsers with all extensions disabled

Any other suggestions would be appreciated. Thank you.

5 Replies

Replies have been turned off for this discussion
  • What is your modem make and model number? What is your gateway wifi router make and model number?

    • eaternet's avatar
      New Contributor

      According to the Cox app, my gateway is the Technicolor CGM4140COM.

  • Your modem or your computer could have a defective Ethernet port. Have you tried connecting a different computer?

    • eaternet's avatar
      New Contributor

      Thank you. I just tried 3 computers. It works fine for one of them. I will try to do some digging if I can find a difference in settings to see if it may be the cause; otherwise I am also inclined to say that it is a defective Ethernet port.