Forum Discussion

DavidROA's avatar
New Contributor
5 years ago


Does anybody on Cox have a working Motorola MG7550 AC1900 modem\router?  My wireless network is slow and devices are slow establishing a connection. Devices sometimes timeout attempting to establish a connection.

Cox techs have been on-site and unable to find an issue.  They say the signal is good.  They found no splitter related issues.

Arrogant Motorola support was not helpful.

So, does anyone have one of these modems working on a Cox network?  In Roanoke, VA?

I would appreciate it if someone could tell me what the upstream and downstream connection status readings should be.

I would greatly appreciate any help.

Thanks for your help!

7 Replies

  • KevinM2's avatar
    Former Moderator
    Hi David, your modem levels look quite nice. I'm not seeing any packet loss, timeouts, or noise. Are you able to provide results of a hard-wired (not WiFi) speed test for us? I'd like to see what download and upload speeds you're receiving. Also, is this happening on the 2.4 GHz, 5 GHz networks or both?

    The 2.4 GHz band offers better Wifi coverage, but is prone to more congestion due to heavy network traffic. The 5 GHz band offers less range, but delivers faster speeds thanks to less congestion and wider channels. Here is some additional information on ways to improve your WiFi service:

    If your download and upload speeds are within the normal range, then you may be experiencing WiFi interference. -Kevin M. Cox Support Forum Moderator
    • DavidROA's avatar
      New Contributor

      I will have to move desktop to the room where the modem is.  I will that this morning and compile some some speed statistics.  Also occasionally I do get some T3 timeout events.  I have tried to research these but can't find anything specific about their cause.

      The modem we had before the Motorola MG7550 worked fine.  The connection speed seemed okay and we had no issues connecting to it.   It was getting old so we thought we were trading up. The old modem was a Cisco

  • Bruce's avatar
    Honored Contributor III

    In your original post, you transitioned from slow wireless to your connection with Cox.  Although both connections (Cox Internet (WAN) & wireless) are housed in the same device (MG7550), there is a dividing line between the 2 connections.  Cox owns 1 side and you own the other.

    Cox and the tech said your WAN connection is fine, so focus on the wireless side.

    Multiple things can cause slow wireless.

    How many devices are on your wireless?
    Are there any walls between the devices and router?
    How far are the devices from the router?

    Considering your router and your neighbors' routers, your 2.4 GHz channel may be too congested.  You could switch your WiFi to a clearer channel.

    2.4 GHz is not just one channel but is divided into 14 channels.  That "2.4" actually has 2 more digits to further increment your frequency into the thousandths:  2.4xx.  Frequency 2.4xx starts at 2.412 and ends at 2.484.  However, North American doesn't use 3 of those channels, so it's actually 11 channels.

    Anyway, you can try to find a clearer (less congested) channel.  WirelessNetView is a good program to scan for a cleaner channel in your neighborhood.  I'm sure other contributors may recommend better programs.

    • DavidROA's avatar
      New Contributor

      here are my Ethernet speed tests. I am directly connected to my MG7550 using a cat5 cable.

      I used the speed test on the Cox site. It was connected to Cox Nova.

      ping = 11ms

      jitter = 3ms

      download = 175.2mbps

      upload = 10.7 mbps

      second test

      ping =11ms

      jitter = 1ms

      download = 3.6mbps

      upload = 10.8mbps

      third test

      ping = 11ms

      jitter = 1ms

      download = 100.0 mbps

      upload = 10.8mbps

      • DavidROA's avatar
        New Contributor

        I am sitting next to my MG7550. Nothing between my tablet and modem. I am using my wireless connection and the cox speed test going to Nova.  I received a socket error on my first try.

        ping = 16ms

        jitter = 4 ms

        upload = 10.0mbps

        download = 26.0mbps

        second test

        ping = 14ms

        jitter = 60ms

        download = 32.5 mbps

        upload = 9.5mbps

        should no obstructions or interference. I am 5 feet from the modem.