Forum Discussion

kbawswfh's avatar
New Contributor
4 years ago

Extreme latency and blackouts while working in Amazon Workspace

All cabling has been replaced, I am direct connected to my Netgear AC1600 modem and currently pay Cox for 300 Mbps Download speed.

When I run a speed test while I am in Amazon Workspace, the download speed is ~77.9.  When I am outside AWS, it's 325.  

I have to use AWS for work and I am unable to work.  The latency is absolutely unbearable and many times my screens completely black out before coming back on, at which time the security protocol pops on indicating I've been disconnected and now am reconnected.

I have  gone through an update on AWS and corporate IT can find no reason for the latency or connect issues on this corporate laptop from their standpoint.

Please help me resolve this problem.  I am at a loss at where else to look to resolve the problem.  

Thank you! 

4 Replies

  • Thoreau's avatar
    New Contributor II

    Had to look up Amazon Workspace as a service I hadn't seen before.  The way you describe it vs. what I'm reading seem a little different, but i think my first stab at a test might still apply.

    Pop open a web browser and slap in (or, or any similar site) and take note of the IP you see.  

    Connect to Amazon Workspace and load up a new browser and same website.

    Is the IP the same?  I'm halfway expecting it to not match, which means traffic in AWS is routing out from the virtualized desktop environment.  Even a local browser vs. one inside the VDE might be affected because I'd bet the system uses a VPN that re routes all traffic on the physical hardware you're using through the secured tunnel.  

    Best guess/stab that I can think of without getting my hands on that kind of setup though.  If correct though, it's either gonna be a limitation of the VDE/VPN tunnel provided which would probably be out of Cox's hands.  

    That kinda issue is part of what keeps me from using always-on-vpn services since regardless of how good the connectivity speeds are on my device, it still won't go faster than what the remote/vpn side will process/allow.

    • kbawswfh's avatar
      New Contributor

      Thank you.  I ran the test you suggested and you are correct.  Outside AWS indicates IPv6 and about a 20 character name and IN AWS is IPv4 and a 10 character name.  Wish I had a choice but because this is my profession and a company requirement, no choice.  there's got to be an option.  I was running it fine up until about 10 days ago.  Welcome any recommendations you might have.  

  • SharonL's avatar
    Former Moderator

    This appears as if you may need someone to investigate your account personally. We would be able to assist you with this. Please reach us on Twitter at @CoxHelp, visit us on Facebook, or email us at Provide us the name on the account with the complete service address with a link to this thread so we can get started.

    Thank you.

    Cox Support Forum Moderator
    • kbawswfh's avatar
      New Contributor

      Thank you Sharon.  We were thinking the same thing. Will send an email now.

      Thanks again!