Forum Discussion

mathjk's avatar
mathjk
New Contributor
3 years ago

Cannot port forward - We're Having Some Trouble Please try again

Hello,

I'm having the same issue as discussed here:

Unable to create or edit existing port forwards (Panoramic Router) - Internet - Internet Forum - Cox Support Forums

However, the thread has been locked without any resolution.

1. Visit wifi.cox.com to set up port forwards, among many other features and settings.

2. Select "See Network" 

3. Select "Advanced settings"

4. Select "Port Forwarding"

5. Select "Add Port Forward"

6. Select the device from the pull down menu, Manual Setup, Port 5555, Protocol TCP

7. Select "Next"

Then the message "We're Having Some Trouble Please try again. If the problem persists, check back later."

I've tried again and again, and checked back for the past 2 days... Still no luck...

Any thoughts on what to do next?

2 Replies

  • mathjk's avatar
    mathjk
    New Contributor

    Well, I've not had much success with cox tech support so far. They tried to up-sell the $10/mo monthly support but why would I have to pay for something that *should* work? Cox is pushing port forward on the device, not me. Getting frustrated here.

    • CrystalS's avatar
      CrystalS
      Former Moderator
      Hello @Mathjk,

      Customer service is very important to us, we value you and I want you to have a positive experience with us. We would definitely be able to assist you with this. Please reach us on Twitter at @CoxHelp, visit us on Facebook, or email us at cox.help@cox.com. Provide us the name on the account with the complete service address with a link to this thread so we can get started.

      Crystal S.
      Cox Support Forum Moderator