This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Roku FoxNews channel login problems

Up until about a week ago we had been using Roku to watch live streamof FoxNews on  our Roku.  The we started getting error which said the service provider is not allowing the content.  After struggling with this for few days, finally got COX to tell me our COX password needed to be re-set.  Why that was needed is a topic for another thread, but I set a new password. 

After removing the FoxNews app and re-adding it to our Roku lineup and logging in again with activation code and COX login, the FoxNew live stream worked again...until the next day.  Then it was locked again.  I had to remove it again, then log back in again.  Then the next day is was locked AGAIN.  What is going on that I have to keep logging in with with the activation code and cable provider once a day!?

No Data
  • I'm experiencing the same issue. Figured I'd post here what I sent to Fox after reading through this thread.

    April 20, 2019

    Fox News Channel (FNC) had been working fine on all Roku TVs in our two homes since we got our second home wired to Cox in about May 2018, but starting around May 2019, FNC would not connect to our Cox account on any device in either home. At the same time, Fox Business Network (which I believe is also part of the Fox News “family”) required reauthorization with Cox and I was able to do so on all Roku devices in both homes. After numerous attempts in both homes I was able to get the TV in the home with the Cox account to connect and stream fine. But, dozens of attempts on all devices in our main home after that failed. The rough sequence was:

    1. Delete and reinstall FNC on the Roku device
    2. Launch FNC on Roku and select Playing Now for a live stream (which shows a lock icon in the lower right of the program)
    3. The Connect screen appears on Roku, asking you to select your cable provider (Cox) and enter the displayed code at
    4. Log into my Cox account on an iPhone browser (I tried both Chrome and Safari), either before or after launching the Connect page (I tried both ways; the sequence didn’t seem to matter)
    5. The Chrome browser then displays the Success page and the FNC app on Roku closes (crashes?) and puts you back on the Roku Home screen.
    6. Repeating the process produces the same results, regardless of which Roku device I’m trying to connect to Cox.

    May 23, 2019

    I called Roku tech support and the rep said the problem may be because Cox limits the number of devices you may connect; this didn’t sound plausible to me because I have not seen this with any other channels that need to connect to a cable account, but I called Cox anyway. He said it also might be an issue with FNC and when asked he gave me their tech support number.

    After insisting that our Cox account has not changed in a year even though our condo association recently signed a new bulk contract with Cox that includes internet (this issue ended up not being germane to the FNC problem) she said she didn’t think that Cox had the ability to limit the number of streaming devices for a channel.

    I called FNC at 888-369-4762 and after navigating their menu was given an opportunity to leave a message, not speak with a tech – which I did. I have not yet heard back but given the runaround and non-helpful info I’ve been getting from Roku and Cox I’m not optimistic that they’ll have a solution.

No Data