Forum Discussion

lazyv's avatar
New Contributor
2 years ago

unable to access call history via voicemail. Wheel just keeps spinning

unable to access call history via voicemail. whel keeps spinning. Recent problem

12 Replies

  • Bruce's avatar
    Honored Contributor III

    I just duplicated this problem.  Yesterday, Cox sent corrupt Caller ID data, so I logged into my account to view my Call History:  My Account > Phone > Settings > Expand Call History...and it just spins.

    I logged out, closed browser, cleared history, retried and it still spins.  I let it spin for an hour and it eventually displayed:  "We're experiencing technical difficulties..."

    I tried again today, same thing.  I downloaded the .csv version of my Call History and except for the headers, it's empty.  Why is everything with Cox so difficult?

    • DavidA2's avatar
      Former Moderator
      Hi Not Important,

      I am sorry to hear that you are having trouble accessing your call history. Are you getting any specific error codes when trying to access it?

      Cox Support Forum Moderator
      • not_important's avatar
        New Contributor II

        it keeps looping and says signing in but I am signed in  It happens when trying to access settings, voicemail or contacts after choosing phone - 4 days now

  • Hi Everyone, an issue has been identified causing attempts to log into and attempts to access Voice Tools after logging into Cox My Account to fail. In most cases, these login attempts result in being repetitively looped back to the sign in page. I appreciate everyone who reported this issue and assisted us with the information and troubleshooting steps you provided. There is no estimated time of repair yet available. I will update this page as soon as I receive notice that the issue has been resolved. Thank you for your patience with this issue and with us! 🙂 -Becky, Cox Support Forums Moderator
  • CurtB's avatar
    Valued Contributor III

    Option 1. Voice Tools shortcut:

    Option 2. If that doesn't work, create a shortcut with the webpage navigation link.

    1. Sign into your Cox account.
    2. Click the   icon in the upper right of your profile page.
    3. Click My Account from the menu.
    4. Scroll down to "Manage services and equipment" and click Phone.
    5. Scroll down to "Helpful Tools" and right click Settings.
    6. Click Copy link from the menu.
    7. Create a new desktop shortcut with the copied link.

    Cox may change something that causes it to break again.  But for now, both options work.

    • Bruce's avatar
      Honored Contributor III

      Getting to the Call History directory is fine because I can view my eMTA and whatever else is on the page.  When I expand Call History, it just spins and if I download my History, it's just an empty .csv file.

      The first time I tried, I could expand the History but after selecting another duration, it began to spin and has only spun since.

      This has happened before and seems to be a reoccurring issue.  Phone > Settings has just been a problematic directory.  I don't know who at Cox maintains it but they don't do a very good job.

      • CurtB's avatar
        Valued Contributor III

        I had issues with call history a couple of times in the past.  Neither issue was what you described however.  I contacted and they opened tickets.  The first one took a long time to get fixed, but Cox's vendor fixed the second issue in 72 hours.  Since your situation is diffferent than the issue described in this thread, you should send Cox an email.  But you know the drill.