Forum Discussion

justininaz's avatar
justininaz
New Contributor II

Very slow download speeds suddenly, no changes were made (upload is fine)

Location is Scottsdale, AZ 85254 if it matters. This is an incredibly frustrating problem that I've spent just about all day and yesterday evening troubleshooting, so it is very long (sorry). I work from home and need my internet working fully to do my job. I am experienced with networking, routers, modems, systems, and troubleshooting, but running out of ideas. I do have a Cox technician coming to my house tomorrow to check the physical/wiring/cabling side of things outside my house.

TLDR: Download speeds suddenly and unexpectedly dropped significantly below what my service is rated for. Extensive testing and swapping modems, routers, PC/laptops, does not point to any single failure point. Cox technicians have no idea what the problem is as everything looks healthy. Max speed was seen in a few tests, but not reproduceable. Slow speeds are consistently reproduceable.

Problem background:

I returned from a 1.5 week vacation yesterday to extremely slow download speeds. Speedtest consistently showed ~30Mbps download and 10Mbps upload. My service (at the moment) was 500Mbps down and 10Mbps up. Speeds were the same whether it was wifi or direct ethernet to my router. Before I left town I had no issues with download speeds, although the last test I have in my Speedtest log was from 5/9/2023 and it was 476Mbps down. Nothing changed with my home network.

Setup is:

- Arris SB8200 bridge mode (self purchased, not a rental)

- Asus AC3100 wifi router

- Several Windows PC's, laptops, mobile devices, Linux server, IoT, etc

Series of events and testing:

Before involving Cox support, I power cycled the modem and router half a dozen times with no changes in download speed. I also directly connected both a laptop, and a wired PC, to the Arris modem via ethernet (bypassing my router) and experienced the same slow ~30Mbps download speeds with both devices.

I logged into my Arris modem directly and the Power and SNR values were all within manufacturer spec, everything was OK and Online, it looked healthy.

I spoke with live support chat a few times, each time going through the same old rigamarole that I had already done. Power cycles, remote resets, health check on their end, etc. Same results, ~30Mbps download, 10Mbps upload, whether connected through my router or direct to the modem.

One agent said my modem was bad because he saw 30% packet loss to the modem from his side, but otherwise it showed healthy on his end. I could see no such packet loss doing my own tests. He insisted my modem was bad, that I should buy a new one, and he would upgrade me to the latest internet package of 1Gig down, 35Mbps upload (for just a couple extra bucks a month). I declined the upgrade package as I wanted to get my problem fixed first. He reset my modem one more time to test and I got disconnected from the chat.

I got another chat agent online and began the process again. While in that chat, I received a text and email that my service upgrade was confirmed, so I guess I now have 1Gig download and 35Mbps upload, even though I declined it...

Not a huge deal...except when I tested the speeds again, my download speed was still ~30Mbps. The upload speed DID update to 35Mbps upload, from 10Mbps, after yet another modem power cycle.

We went through the same old troubleshooting that I had done countless times up to this point. Again, same slow download speeds. When they asked how old my modem was, I told them ~3 years old. To which they responded "wow, you need a new modem!"....At that point I was tired of chatting with support.

I called support on the phone, hoping to get a technician dispatched. Again, went through all the same troubleshooting, only to be told they cannot send a tech out unless my service was completely down. Oh, I was told to get a new modem again and they assured me it would fix my problem (despite them saying everything looked fine on their end).

So, I went to Best Buy and bought a brand new Arris SB8200 modem.

I called Cox support again and got a technician on the phone to register my new modem. After a bunch of waiting, the modem rebooting, and provisioning seemingly many times, it got all setup and connected. I tested again and as I expected, same problem, download speeds of only ~30Mbps. This was with my laptop directly wired to the new SB8200 modem, bypassing my router. 

The technician on the phone said everything looked good on his end and he was at a loss, he forced provisioning/resets a few times and could see nothing wrong. When I logged into the modem directly, the Power/SNR values all looked nearly exactly the same as my original modem (in spec).

With the tech on the phone, I tested with my router connected to the modem, then directly to my PC again, and back to my laptop directly. All tests were the same with ~30Mbps download and 35Mbps upload.

Here is where it gets even more weird...

While on the phone with the tech, I asked him to make my original modem the active one in the system, so I could use that and return the new one I just spent $150 on. I unplugged the brand new modem and plugged my original modem back in. I had him wait until it was back online to make sure it worked and I had at least some internet connectiviy. It came back up and I still had the same slow download speeds. I was directly connected to the modem with my laptop via ethernet.

Next, he started working on scheduling a technician to come onsite as he was out of ideas (this tech was the most helpful of the 5 or 6 I had already spoken to). This took a while since he couldn't just send out a support tech apparently, since my service got changed (somewhat unintentially) and he needed to find a service installation tech (different schedules/techs?).

While he was doing this, I hit Go on my speedtest app again for the heck of it, and suddenly I had ~950Mbps download!?!? What the heck? I told him and he said he didn't do anything and had no idea why it was working. I had not changed anything either.

So, I disconnected my laptop from the modem and plugged my router into the modem to test. Power cycled the modem and router again and waited for connectivity to come back. I tested both wired and wifi machines and again it was back to ~30Mbps. Soooo, bad router? Doesn't make sense, since it has worked fine up until just recently, and only the download is broken.

He scheduled a tech to come onsite and we left the phone call.

I then got out a backup Linksys router and factory reset it, to confirm if it was a router issue. I configured it with basic settings and power cycled the modem. Router came up with a WAN IP and I had internet connectivity. Speed tests still showed only ~30Mbps download, upload was fine at 35Mbps.

I got out another backup router, Asus AC1900, factory reset it and connected it to my modem. Power cycled the modem, let router get WAN IP and connectivity. Tested again and still had slow download speeds.

I again switched back to directly connecting the modem to my laptop, via ethernet. Power cycled modem, waited for it to re-establish connectivity. I expected to see ~900Mbps download like I had just seen earlier, but no, it was back to being slow at ~30Mbps download.

Once again I called support and the initial support person said I needed to talk to the "CAG" group with internet team. They transferred me there and I explained everything that had happened and asked to get an expedited tech onsite (the original scheduled tech was over a week out). This tech ran several tests again and said everything looked fine. While on the phone with this technician, I again ran the speedtest while connected directly to the modem and the download speeds WORKED again for a 2nd time. I saw ~950Mbps download. Again, nothing was changed, but I was able to reproduce the test a few times.

I connected my original router back up and once again it went back to slow speeds, ugh. The tech was able to find an onsite window for tomorrow (Tuesday) so I took that and we dropped the call.

After that, I again reconnected my laptop directly to the modem to test again. This time, speeds were back to being slow at ~30Mbps, even directly connected, when it worked just 25 minutes prior (as seen in image below).

As I am typing this, directly connected to my modem with the laptop, I am still seeing slow speeds of ~30Mbps download. I have no idea why it worked a few times and neither do any of the Cox technicians.

If there are any ideas out there I would love to hear them. The only consistent behavior is slow speeds when the modem is connected through ANY router. But, the router connection was working fine for years up until a week or two ago. Plus, I've tested 3 different routers. Fast download speed happened mysteriously a few times when directly connected to the modem, I cannot reproduce it successfully, and most of the time it is slow ~30Mpbs or less download.

Below image are tests from my laptop. The ~900Mbps download tests only happened when directly connected to the modem. However, several of the ~30Mbps tests were also directly connected to the modem (as well as the router). I did several other tests on my PC, so not all of them are in this image.

22 Replies

  • WiderMouthOpen's avatar
    WiderMouthOpen
    Honored Contributor III
    I logged into my Arris modem directly and the Power and SNR values were all within manufacturer spec, everything was OK and Online, it looked healthy.

    Can you post the signal levels so we can take a look too? I am curious if you have 2 OFDM channels. 30-32Mbps is around the max speed of DOCSIS 2.0 so I wonder if your modem is failing back to that.

    One agent said my modem was bad because he saw 30% packet loss to the modem from his side

    Did you see any packet loss going out, direct to the modem, when he did his test? Try Pingplotter or WinMTR to look at your latency/packet loss over time.

    • WiderMouthOpen's avatar
      WiderMouthOpen
      Honored Contributor III

      I just found a way to check the configuration file on the SB8200 to confirm the provisioned speed. See last post by Andyross here.

      "replace "comconnectstatus" with "main" in the URL, and it will show the config file."

      Does that work for you? What does it show next to configuration file?

      • justininaz's avatar
        justininaz
        New Contributor II

        Below are the modem signal levels and details. Odd thing is, it looks like the modem got a firmware update since yesterday, as the login screen was different and my password no longer worked. I had to factory reset it to use the default login/password combo.

        I also got a 404 when trying the "hidden" main page, that info seems to be part of the Status page, minus the extra details.

  • justininaz's avatar
    justininaz
    New Contributor II

    Just to add some additional testing I did late last night. I tried my AC1900 router again, after factory resetting it. Connected it to the SB8200 modem and rebooted the modem. This time, I had ~900Mbps download speeds going through the AC1900 router, with my wired laptop!

    I then tried to switch it over to my AC3100 router, without rebooting the modem, but my router had a WAN error that said "Your ISP's DHCP does not function properly". So, I rebooted the modem and the AC3100 router, and let it all come back up and online. I then had ~900Mbps download through my AC3100 router. At that point it was after midnight and I went to bed, hoping for the best.

    However, I got up this morning and everything was back to ~30Mbps download 😞 Several modem reboots already and no change, ~30Mbps download.

    • WiderMouthOpen's avatar
      WiderMouthOpen
      Honored Contributor III

      Hmm, if the speed is coming and going, I doubt it's the config file. Could you post your signal levels? Also, anything critical in the logs? Maybe a failed firmware upgrade? Partial service error?

    • Darkatt's avatar
      Darkatt
      Valued Contributor III

      You have to reboot the modem each time you change the WAN connected device, or it won't work. Rebooting the modem allows the new MAC ID of the other device to reach out via DHCP to get an IP address. Try connecting your laptop direct to the modem,. reboot the modem so the laptop can get an IP address, ensure both wireless routers are powered down, or disable wifi on the laptop so it doesn't try a wireless connection, even though your connected via ethernet and run the speed tests, and it should look good. 

      Wireless 2.4 GHZ on 500 mb down, 50 up - https://www.speedtest.net/result/14979584181\

      Wireless 5 GHZ  https://www.speedtest.net/result/14979590535

      Can't give you ethernet, main computer is crunching a blu-ray dvd for my plex

      • justininaz's avatar
        justininaz
        New Contributor II

        I have done exactly that process countless times and almost always get ~30Mbps download speeds (as detailed in my original post).

        I tried a cable swap from router to router as a test, which obviously didn't work. Rebooted the modem and router and I had 900Mbps download. Went to sleep and woke up to 30Mbps, nothing was touched on my end.

        I still have 30Mbps today, whether I am direct connected or through my router. Modem is power cycled each time I switch devcies. See widermouthopen posts about the ch159 OFDM SNR values, or lack there of. 

  • Lovemylab's avatar
    Lovemylab
    Contributor III

    No useful suggestions based on what you have reported. I am sure this is frustrating. The only longshot I can think of is to run a traceroute to a standard destination, and rerun when you observe the speed increase. If you see an obvious routing change that might point in the correct direction, but I don't know who you would report it to.

  • I live in Phoenix and have similar speed problems. I’m not nearly as tech savvy as you are but I feel like I’ve tried the basics to no avail. Sent an email to the Cox Help and haven’t heard a peep in 4 days. Please let us know if the tech is able to fix your issues.

    • justininaz's avatar
      justininaz
      New Contributor II

      He was! The issues have been resolved and I now have consistent ~950Mbps download and the 35Mbps upload. I had to call Cox support on the phone several times and insist on getting a tech to come out, it was a painful process. If you call the internet support phone #, ask them for the "CAG" team. They seem to be the escalation level people with a bit more technical depth, they also scheduled my tech onsite.

      As for the resolution -

      First, there was no issues with my equipment, thankfully. It was all wiring and connector related issues that I'm suspecting have just been getting worse over time. Hence the intermittent problems.

      The short version is that there was a few issues with the coax wiring/connectors, both at the Cox box on the street, and the box on my house that goes inside. Once the tech upgraded the connectors and eliminated unneeded old components, everything worked great. I moved into this house in the middle of the pandemic (late 2020) and I believe they were not sending techs onsite for setup, unless required. So, I never had the wiring/connectors checked out until now.

      Longer version -

      The box on the street, where the main cable lines come in, had some old legacy components for phone lines, that was sending electrical current down the internet cable (this was bad according to the tech, creating interference). He removed that piece, which was a small resistor looking thing on a board that the coax connected into.

      On the house side, pictured below, it also had legacy telephone junk in it. The main internet line is on the left, shown outside of its connector sleeve. The tech said it was barely in the connector and just pulled right out. He thought that was probably causing the majority of the issues as he couldn't even get his test device to fully connect from inside the house.

      The line going into the house is on the right, with the connector that has a green stripe on it. This connector is some sort of signal reducer (booster?) that is not supposed to be used anymore and also causes signal/connectivity issues (I forget the details exactly). The tech removed that whole box and replaced it with a new one that simply connected the main line from the street directly to the house line. The lines were stripped and had new connectors installed, and also removed the signal reducer piece.

      Once everything was re-done, it tested out fine on his device and we booted up the modem and my router. All looked good on the modem and the OFDM value was now way higher than before, so good catch widermouthopen. Speed tests with wired connection now look good in the 900Mbps range, upload still working as it should at 35Mbps.

      Old lines and connections:

      New line connectors:

      • CuriousJ's avatar
        CuriousJ
        Contributor

        Thanks for the update and congratulations for getting Cox to actually fix something!