Forum Discussion

JS3's avatar
New Contributor

unsolicited mail overload.

I appreciate having access to this forum BUT I do not wish to receive all the emails. The "unsubscribe" link does not turn them off. Block sender does not work. I really need to limit the volume of unsolicited email. Your assistance would be appreciated. JS

2 Replies

  • @JS3, You can disable all email notifications under the settings menu. You will want to uncheck the blue box that is next to Enable Email Contact. -Allan, Cox Support Forums Moderator.
  • Bruce's avatar
    Honored Contributor III

    I reviewed your public profile and it appears you joined the TV Forum on 7 Apr 2019 (1 year, 10 months and 26 days ago).  If you join a Forum (Internet, TV, Phone, Apps); you'll get spammed with everything occurring in the Forum(s).

    Click your profile pix in the upper-right > Profile > Groups > then unsubscribe.