Forum Discussion

Tom2001's avatar
Tom2001
Contributor
9 months ago
Solved

Refresh required after email deletion

With the new version of Cox webmail, when I delete an email or multiple emails and hit the trash icon the emails get hi-lighted but the inbox is not refreshed and the emails stay on the screen. I have to refresh or go to another folder and back to the inbox before they are deleted from the screen. This happens on Chrome and Safari as well as on MacBook and iPad.
Can this be reported as a bug please?

  • Its not he message count on the folder, the deleted emails remain in the main body and are dimmed but not removed from the main body. Yes you can go back and forth between folders and the main Inbox will be refreshed.

    The last 2 days the problem has disappeared and the deleted emails are immediately removed from the main body.

    Thanks for your input on this and I hope to not revisit again, I appreciate your input on the forum.

24 Replies

Replies have been turned off for this discussion
  • purple2221's avatar
    purple2221
    New Contributor

    Good Day to all,

    My email has been a pain since the update a few months ago  .  It appears the same for others. 

    Can not find a fix.  

    • CurtB's avatar
      CurtB
      Valued Contributor III

      You joined the forums just to say you can't find a fix for an undefined problem?   If you're talking about the message count, it's a minor issue that actually does have a workaround

      • Tom2001's avatar
        Tom2001
        Contributor

        A minor issue? Please read the full description (and I have submitted it to Cox as a bug and they know about it), it not about a simple number next to folder. Your workaround of manually going back and forth to reset stuff is a cop out for the developers. Have them fix properly. 

        BTW I have been active in the forums for years and have been a Webmail user for 20 plus years.....

  • WiderMouthOpen's avatar
    WiderMouthOpen
    Esteemed Contributor

    Thank you for reporting yet another bug. If getting webmail bugs fixed is anything like getting forum bugs fixed, expect a long, painful, pointless prossess. I am not even sure the company Cox outsourced changed or they just changed UI. 

    • mrow2's avatar
      mrow2
      New Contributor

      I have hated this slow site ever since I was introduced to it.  I use it for voicemails.  It is excruciatingly slow to load, play and then delete with ridiculous waits between actions.  I do not recall that my latest three voicemails were also transcripted and I believe they were not. What is going on with this poor service?    I am using a powerful but older Pavillion PC, and have a decent internet speed for two household members and 1 to 2 devices on with vvery light duty at any given time. 

    • Tom2001's avatar
      Tom2001
      Contributor

      Well sadly the zombie deleted emails are back after deleting them. It was working well (emails removed from INBOX after selecting and "Trashing") and if over the weekend but is failing once again. Has this been reported as a Bug and if so is there confirmation that it is a BUG and estimated timeframe to fix?

  • CurtB's avatar
    CurtB
    Valued Contributor III

    It doesn't do that for me.  When I delete one or more emails from Inbox (delete icon, delete button or right-click Inbox > delete all messages > empty folder), they're removed from Inbox and appear in Trash.  I don't think browser matters, but it's the same with Edge and Chrome on a desktop PC.

    What do you mean by "when I delete an email or multiple emails and hit the trash icon"?  It sounds like you're doing two things, but there is no "trash" icon.  Do you mean "delete"?

    Do you have other browser tabs open when you delete the messages?  Could your computer be performing a processor intensive task?  If you wait, do deleted items ever disappear from Inbox and appear in Trash?

    Maybe it's an Apple thing. 

    • Tom2001's avatar
      Tom2001
      Contributor

      When I check the box on an email or multiple emails I can then choose to delete them by clicking on the Trash Can Icon. The slected emails then get hi-lighted, deleted from the inbox but remain as zombi like emails in the inbox display. I then have to go to another folder or the Trash and then go back to the inbox to see them disappear.

      I have other Tabs open and have tried it with just one tab open - same results. Only started happening with the New and Improved version a few weeks ago.

      I have a hi end macbook....nothing intensive but cox webmail running.

       

      • CUTiger78's avatar
        CUTiger78
        New Contributor III

        Tom2001, I'm in the same boat as you, except I'm running a reliable HP Envy PC. It didn't start happening immediately with the new e-mail app, but just started w/in the last week. Also, doesn't seem to be as bad in the middle of the night when the Cox server load must be lower. If this keeps up, I'm gonna have to find another mail app.

  • CurtB's avatar
    CurtB
    Valued Contributor III

    If a folder's number of messages indicator doesn't update after moving, copying or deleting messages, it can be manually updated by clicking the "Refresh" button or automatically with the next timed refresh.  The minimum refresh interval is 5 minutes.

    Settings > All settings > General > scroll down to Advanced settings > Look for new data every {5 minutes, 10 minutes, 15 minutes, 30 minutes}.

    However, neither of the above should have to be necessary for a basic houskekeeping function.    After the move, copy, or delete subroutine successfully completes, the existing refresh subroutine should run... to reset indicators.  This should be an easily correctable coding omission with virtually no processing overhead.  But, that doesn't mean it will happen anytime soon, if ever.

    • Tom2001's avatar
      Tom2001
      Contributor

      Well all morning the deletion of emails has been working with the client (web side) of webmail processing the deletes of selected emails and removing them from the inbox display. This is clearly a web side (not server) issue that hopefully they have fixed. I'll keep the forum posted on results.

      BTW, why don't we get email notifications when the thread we are interested in or started has activity? 

      • DannyS's avatar
        DannyS
        Moderator

        Hello, we are aware of concern regarding some accounts with the proper deletion of emails.  We also, are aware of the missing notifications when a forum has been updated.  We do not have a restoral time on either but look to have both fully addressed as soon as possible. 

    • RobertS1's avatar
      RobertS1
      Moderator

      Thank you again for reaching out to us it was a pleasure working with you. Have a wonderful night! Always feel free to reach out to us any time the Social Media team is here 24 hours a day, 7 days a week to help. 

  • jneel5's avatar
    jneel5
    New Contributor

    I have the same issue. It doesn't always update after refresh but appears to update after I select a different folder then come back to the Inbox. Thanks for posting this because I can't get tech assistance at the moment. This is a major bug.

     

    • ChrisJ2's avatar
      ChrisJ2
      Moderator

      Hi, there. I'm so sorry for the issue with the interface not removing mails. We'd like to help you resolve it. Please email us the physical address and any other pertinent information to Cox.Help@cox.com with your name and a copy of this forum message. We really want to help you get this fixed. 

    • Tom2001's avatar
      Tom2001
      Contributor

      I hear ya.....what are the paying the developers in India.....?

    • CurtB's avatar
      CurtB
      Valued Contributor III
      jneel5 wrote:

      This is a major bug

      If this is something you consider a major bug, you must have a pretty easy life.  😊  The emails are deleted.  The messages count should update properly all the time and should be relatively easy to fix, but it's just a cosmetic issue.  BTW, the message count updates correctly for me.

  • Webmail not refreshing and not removing deleted emails will work fine one day and then stop working the next......very frustrating.

    I send you my address and the URL of this thread.....Please run this up the bug list so the developers no about it. (again)