Forum Discussion

azboone's avatar
azboone
New Contributor
24 days ago

Paying for 1gig, getting less than 100 mbps

We moved into this house a couple years ago and started our internet service with 250 mbps package for $99/month. We consistently had issues with service speed and data overages. A few months ago we upgraded to the 1 GB package and are now paying $166/month. We continue to have service speed issues and consistently test speeds from 25mbps to 90mbps. 
We have upgraded the modem. We have made multiple calls for technical support where we spend 30-45 min on the phone without any resolution. We have asked for a service technician but none has been scheduled. We have installed Ethernet ports to have more wired connections. I’m currently searching for other service providers to help me resolve this issue. I’m frustrated that it has been this hard to get help to fix my service.

1 Reply

Replies have been turned off for this discussion
  • azboone 

    I'm so sorry to hear you've been having trouble since moving in. I would be frustrated too if I expended so much effort without a resolution. 

    Please know the purpose of the Cox community forums is to allow customers to discuss technical topics related to residential Cox services with other customers and we encourage our users to assist each other where possible via this avenue. 

    Billing, account and some service issues require the sharing of sensitive information to resolve which isn't best suited for a public forum. Please email us at cox.help@cox.com with your full name, complete street address, the details of your concern and a link to this post. You can also reach us on Twitter/X  @CoxHelp, or visit us on Facebook.

    Because this post falls outside of the purpose of our forums I will be turning off replies to this thread. We look forward to receiving your email so that we may assist you.