Forum Discussion

Millerd_69's avatar
Millerd_69
New Contributor
7 months ago

Panoramic WiFi Router from Cox plus 500mbps Unlimited and Roku(s) drop signal

I can not watch  a movie or even a TV show for that matter, on any Roku players or TCL TV with Roku built in without white dotted wheel spinning every 10 or so minutes.  This has ONLY been a problem since my account was upgraded from 250 Mbps to 500 Mbps intrernally within Cox.  I did not have this problem before unless my kids had a bunch of kids over.  I just finished trying to watch a movie this evening as tomorrow is my birthday and here I am at 1 am dealing with Cox crap again.   I pay $155 a month for JUST internet and I can't watch a 30 min show without wanting to cancel my service.  Oh, im not in contract either    Humm!!? I'm somewhat versed in this stuff but really CenturyLink starting to sound better and better I tell ya.   Any help big or little I appreciate  

           Thanks in advance, 

              Guy who Cox doesn't work and didn't get worked after cause I'm here instead 

2 Replies

  • Hi. The purpose of the Cox Internet Forum is to allow customers to discuss technical topics related to residential Cox Cable, Telephone and High-Speed Internet services with other customers. This appears as if you may need someone to look into your account personally. We would definitely be able to assist you with this. Please reach out to us on Twitter at CoxHelp via DM, visit us on Facebook via private message, or email us at cox.help@cox.com. Provide us the name on the account with the complete service address with a link to this thread so we can get started. - Lisa, Cox Support Forums Moderator

  • Darkatt's avatar
    Darkatt
    Valued Contributor III

    Have you tried streaming on a device connected via ethernet?