Forum Discussion

brizon's avatar
New Contributor
6 years ago

Can't change 2.4ghz wireless channel using Cox MyWifi

I logged into Cox MyWifi.  Under advanced settings I tried to change the channel for 2.4ghz.  No matter what I do, it still stays on the same channel as before.  

3 Replies

  • FormerMember's avatar
    Former Moderator

    You'll have to log directly into the modem to do that using your web browser. If you have the Panoramic modem, enter "" into the address line and press "Enter". You will then be presented with the modem log-in screen. The Username is "admin" and the Password is "password". You will then have full configuration access to the modem.

    For a different modem the process is the same but the IP address and default Username/Password may differ. Google them.

  • Hi Brizon,

    Thank you for contacting us via Cox Forums. If you’re having difficulty managing your Network Settings, we can help. Please email our team at with this post, your full name, and complete address.

    Maria L.
    Cox Support Forum Moderator
  • FormerMember's avatar
    Former Moderator

    Being curious, I diddled around and actually got Cox MyWiFi to work. I had to:

    - Set my device as a "Trusted Computer" using my web browser (logging in to the modem directly)

    - Set my browser to accept third party cookies for  * (I use Chrome)

    - logout of

    - set the firewall to "Medium"

    MyWifi has never worked before in terms of configuring channels. It does now.

    PS: I have the Panoramic modem/router.