Forum Discussion

jfleming116's avatar
jfleming116
New Contributor
3 months ago

Cannot configure any email client

Hello, i changed my cox email. when i started outlook it asked for password for imap and smtp servers.

I added new password.  But was continually for password for smtp server.

So, i deleted account, and "ADDED ACOUNT" in outlook

Put in all the proper credentials, still same, asks for SMTP password.

 

tried Thunderbird and google, both allowed add, but both fail sending.

 

thunderbird says :-

 

Can someone help please, Cox tech support ???

9 Replies

Replies have been turned off for this discussion
  • WiderMouthOpen's avatar
    WiderMouthOpen
    Esteemed Contributor
    jfleming116 wrote:

    tried Thunderbird and google

    By Google, do you mean Thunderbird and Gmail gave the same error?

    Also, try port 587 instead and choose StarTLS for encryption.

      • RaquelD's avatar
        RaquelD
        Moderator

        Hello, you can find the settings for using third party clients for your email here: https://www.cox.com/residential/support/cox-email-server-settings.html Cox has a complete care service if you have specific issues with the application you are trying to use. This is a fee based service should you need it. I apologize that your email client is giving you trouble. If you have any other questions please email us at cox.help@cox.com and include a link to this thread. You can also reach out on Facebook, Twitter/X, Instagram, or by phone if you need further assistance. Thank you for choosing Cox for your services and for being apart of this community.

  • Thank you for bringing this to my attention. I have updated the link.

  • rampart51's avatar
    rampart51
    New Contributor II

    I've been dealing with the same problem for months. I can't get ANY email client to send emails. I've tried all the combinations....nothing fixes it. COX has been no help unless you want to pay extra for support. I'm already paying 90/month for internet and they want more to answer the phone when something goes wrong.

    The only way to send emails is using the COX WEB based email.   myemail.cox.net