Forum Discussion

kmteddy's avatar
kmteddy
New Contributor
3 years ago

Blocked Senders list

I was blocking senders in my In Box and received the following message:

"You exceeded the maximum number of items on your blocked senders list. Please delete some addresses first.".

I've looked everywhere but can't find my "Blocked Senders list.

HELP ! ! !

6 Replies

Replies have been turned off for this discussion
  • CurtB's avatar
    CurtB
    Valued Contributor III

    "Blocked Senders" only sends email from individual senders to Spam and it's limited to 250.  A better solution is to use Filter Rules to block (Spam or Discard) email from multiple senders.

    Webmail > Settings icon   >  Settings > Inbox > Spam settings > No Spam filtering > Filter Rules > Add new rule      See Filter email using the sender's displayed name

    Note: Filter Rules do not apply to email caught by a Spam filter.   Turn off Webmail Spam filters to ensure all email received is filtered by your Filter Rules.

    The Cox website referenced above also indicates:

        "View the list of up to 250 email addresses or domains you've blocked..."

    However, "Blocked Senders"  doesn't provide functionality to block (send to Spam) email from an entire domain.  Only individual senders can be included.

    Even when the Webmail Spam setting is set to "No Spam filtering", existing "Blocked Senders" will still send email received from those individual senders to Spam.  Filter Rules that apply to any of those Blocked Senders will also run.  If your Filter Rule Action is File into Spam, one copy will go to Spam.  But if your Filter Rule Action is File into any other folder, Blocked Senders will send one copy to Spam and your Filter Rule will send a second copy to that folder.

    Identify common factors for accounts in your “Blocked Senders” to be the Condition for Filter Rules that allow multiple senders to be blocked with the same rule.  Create a Filter Rule with that Condition and an Action of  "File into” Spam.  Then delete those items from ”Blocked Senders”.  When comfortable it works, change the Filter Rule Action to "Discard".  Create similar Filter Rules for remaining items in "Blocked Senders" and delete from "Blocked Senders".  You will no longer see Spam from those senders.  Continue to create additional Filter Rules as needed.

    • Bruce's avatar
      Bruce
      Honored Contributor III

      Expertly done!  Have you maxed your Filter Rules yet?

      • CurtB's avatar
        CurtB
        Valued Contributor III

        Note: My previous post was edited to add content since your reply.

        No, I'm not aware of a limit on the number of Filter Rules.  User Mick536 asked that question and the moderator's reply didn't mention a limit.  See this thread.

  • Bruce's avatar
    Bruce
    Honored Contributor III

    Click the Sprocket in the upper-right > Settings > Expand Inbox in left pane > click Blocked Senders

    • kmteddy's avatar
      kmteddy
      New Contributor

      Thanks, that worked great.  With the ever increasing span out there, can Cox expand the folder to hold more?

      • Bruce's avatar
        Bruce
        Honored Contributor III

        From what I've noticed while confirming the location of Blocked Senders, there are other features to block addresses.  I'm not an expert on webmail.  Our resident expert is curtb and he usually checks the Forum daily.  I'm surprised he has yet to guide you.