Forum Discussion

MrOBrian's avatar
New Contributor
7 years ago

Homelife Hub doesn't handle network name change well

It took me nearly a dozen attempts, over the course of 2 days, to get my Cox Homelife hub to reconnect after changing my network name. I had finally gotten around to giving my networks a personalized name and password, and having done that (and testing that everything was working) I went into the Homelife app on my phone and it walked me through getting reconnected.  I followed the directions through changing the network on my phone so I was connected to the hub, then telling the hub the network name and password. I know I had the network name and password correct because I had just gone through the process on all of my devices and was looking at the info in the admin console of the router. The hub failed to connect over and over and over, until I just gave up. The next day I tried again. And again. And again. Then suddenly it worked. I had gone through the same process, entering the same information, every time, so I have no idea why it failed so many times, and the app doesn't really give good feedback as to why it failed.

For anyone else having this problem: just keep trying and hopefully you'll get lucky and it will work.

Technology should make our lives easier, not frustrate the ** out of us and turn switching on and off a light into a multi-step process that fails far too often.