Forum Discussion

prettysavvy's avatar
New Contributor
3 years ago

Cox app technical difficulties

I haven’t been able to sign in to the Cox App for weeks now on my iPhone 13 PM. When I enter my username and password, I get “Error. We are experiencing technical difficulties. Please try again later.” I am able to sign in to my account through my browser (Safari). I’ve already uninstalled and install the Cox App again, yet still getting the same error msg. The Cox App is much more user friendly than the Cox mobile website, by the way. And no, I’m not referring to your contour app or other services app, I’m specifically talking about the Cox App.

5 Replies

Replies have been turned off for this discussion
  • BenS1's avatar
    Former Moderator
    Hi @Prettysavvy

    I know how important it is for you to use the Cox app. Are you unable to use the app when you are connected to your home wifi as well as using your Mobile data? Also, have you cleared the Cache in the app? Which version of the Cox App are you using?

    Ben S.
    Cox Support Forums Moderator
    • rgriggs1's avatar
      New Contributor

      I have not been able to log into the mobile app either for over a week now. States you are experiencing technical difficulties. Please try again later.

      • Yes, I have cleared all the cache and uninstalled then re-installed the app. Also tried to login on the cox network and the cell network.

      Samsusng S10

      • MariaL's avatar
        Hi rgriggs1,

        We do not have any reports of an issue with the Cox app. Please ensure you have the latest version of the app. To do that, open the Play Store app, then select Menu> My Apps & Games to see if there is an update available for the Cox app.

        If you do have the latest version, then try to clear the app from memory and relaunch it. Do this by tapping on your phone’s menu button (rectangle button on the right on Samsung devices and the square on the right on Nexus devices.) Then you will be presented with a scrollable list of running apps. Simply swipe the Cox app to the right or left to clear it from memory and then open the app again.

        If that does not work, you can try clearing the app’s data. Navigate to Settings > Apps > Cox App > Storage > Data. Tap OK to clear the data and relaunch the app.

        If none of these steps have worked and you are still having an issue, you can send us feedback from within the app. Email us by going to Support > App Feedback. This will allow you to send an email to both our development and support teams to look into your issue.

        Cox Support Forum Moderator