This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Nomorobo Still Not Working

My nomorobo is still not working. Nomorobo has worked on it. They say everything is set up correctly. They told me to call Cox to reset the simultaneous ring because that seemed to be the issue. I did that. Cox says they reset it.   It is still not working.  Not a single call has been blocked this month.  What do i do now?

  • Hi Lily2, I'd like you to turn the Simultaneous Ring feature off and back on using Phone Tools. Log into with your Primary User ID and password. Click Settings to expand the drop down options, and toggle the Simultaneous Ring button to OFF. Then, toggle the Simultaneous Ring button to ON. Enter the number provided by Nomorobo into the phone number box and click the Add button. Then click the Save button. (To find your Nomorobo Number, log into your Nomorobo account at and go to "Your Phones." Your Nomorobo Number will be Highlighted in yellow.) After adding and saving the Nomorobo number in the Simultaneous Ring section of Phone Tools, click "Test" next to your phone number on the Nomorobo "Your Phones" page. Choose "I'm ready. Call me now." See if the test is successful and if Nomorobo begins blocking calls. -Becky, Cox Support Forums Moderator
Reply Children
No Data