Internet keeps dropping and help desk and techs are not able to fix

For nearly a week now I have been getting outages.  This happened last month then stopped, and was happening a few months ago for a few weeks.  It's been really annoying.

Call center keeps having me swap modems.  I've also replaced my router.  They've had a tech out and he said everything tested good.  (I literally have 1 device in the house; cable modem When it happens, everything drops for a few minutes.  I lose discord calls (though I can hear people for about 20 seconds before the entire call disconnects).  I get lagged out of games, and my work VPN connection drops.

The sb 8200 I have reports stuff like this at the exact time the drop happens:

"No Ranging Response received - T3 time-out;CM-MAC=8c:61:a3:cb:dd:dd;CMTS-MAC=70:01:b5:cc:e9:5a;CM-QOS=1.1;CM-VER=3.1;"
11/05/2019 18:01
82000400
3
"Received Response to Broadcast Maintenance Request, But no Unicast Maintenance opportunities received - T4 time out;CM-MAC=8c:61:a3:cb:dd:dd;CMTS-MAC=70:01:b5:cc:e9:5a;CM-QOS=1.1;CM-VER=3.1;"
11/05/2019 18:01
74010100
6
"CM-STATUS message sent. Event Type Code: 24; Chan ID: 159; DSID: N/A; MAC Addr: N/A; OFDM/OFDMA Profile ID: 2.;CM-MAC=8c:61:a3:cb:dd:dd;CMTS-MAC=70:01:b5:cc:e9:5a;CM-QOS=1.1;CM-VER=3.1;"
11/05/2019 18:01
74010100
6
"CM-STATUS message sent. Event Type Code: 16; Chan ID: 159; DSID: N/A; MAC Addr: N/A; OFDM/OFDMA Profile ID: 2 3.;CM-MAC=8c:61:a3:cb:dd:dd;CMTS-MAC=70:01:b5:cc:e9:5a;CM-QOS=1.1;CM-VER=3.1;"
11/05/2019 18:00
82000500
3
"Started Unicast Maintenance Ranging - No Response received - T3 time-out;CM-MAC=8c:61:a3:cb:dd:dd;CMTS-MAC=70:01:b5:cc:e9:5a;CM-QOS=1.1;CM-VER=3.1;"
11/05/2019 17:58
74010100
6a fe

I don't know what to do, but this is ruining my internet experience :(