Forum Discussion

Frustrated_wit1's avatar
Frustrated_wit1
New Contributor
3 years ago

mini box

My mini boxes are junk.   I have called so many times regarding issues and they are never corrected.  Everyone resets the boxes and then tell me they don't know what is going on.  One box simply no longer will receive a signal.   It is not the wiring because the TV on the wall in the room behind it works fine.  Another box will not show certain channel like 13.  The channel is scrambled.  All other channels work.   I called they reset the box and nothing.   No one can tell me what the message M.3.1.4 means.   They just want to sell me the in home maintenance plan so they can change the wiring.  I am a loyal customer for over 20 years and the fact you want to up my bill even more to sell me a maintenance plan before you fix the problem is a joke.   I feel like if I purchase the plan Cox will replace wires that were fine and claim that was the problem.   I am so frustrated and ready to cancel all service with Cox.    No one is helpful or honest. 

5 Replies

  • Hi,

    We'd be happy to investigate this issue and address your concerns; however, we will need some additional information in order to do so. Please email our team at cox.help@cox.com with this post, your full name, and your complete address. You can also reach out to us on Twitter and Facebook through the links below:

    www.facebook.com/.../

    https://twitter.com/CoxHelp

    Maria
    Cox Support Forum Moderator
  • Bruce's avatar
    Bruce
    Honored Contributor III

    I'll assume there is a coaxial splitter connecting the 2 adjoining TV sets.  A splitter will eventually go bad and when it does, it's usually during seasonal changes, ie, heat, humidity, etc.

    You don't need to pay somebody to do this.

  • JeanneO's avatar
    JeanneO
    New Contributor

    I just started having a similar issue. Only 1 of my 3 mini boxes has started having signal interference on most or all channels over the last couple of days. We've checked all cable connects and they're not loose or anything. We've reset the box, and Cox has reset the box, but we still have the problem and keep getting the message M.3.1.4. It's just the one mini box, the other two are fine.

    • BenS1's avatar
      BenS1
      Former Moderator
      Hi @JeanneO

      I regret to hear that you are having issues with your Basic box. If only one is acting up then you need to get that basic box swapped out as soon as possible.

      Ben S.
      Cox Support Forums Moderator