Forum Discussion

Jip's avatar
Jip
New Contributor II
10 months ago

Cox Cable TV out for past 7 days.

My Cox cable TV has been out for the past 7 days. Is it possible to obtain general information on the cause of this outage and when service might be restored?

6 Replies

Replies have been turned off for this discussion
  • WiderMouthOpen's avatar
    WiderMouthOpen
    Esteemed Contributor

    Not from anyone here. This is a user helping user forum. If you post your state or zip code others might be able to say they are having similar problems but other then that, not much we(the users) can do. You might get some kind of answer by contacting Cox using one of the methods on the Welcome thread. If you do find something out, be sure to report back to the forum so others may be helped.

    BTW, Did chat send you here by any chance?

  • Jip's avatar
    Jip
    New Contributor II

    I'm in Scottsdale, AZ 85259. My neighbor's Cox TV has been out, too.

    I have been receiving regular texts from Cox that they are working hard to get service back up...for 7 days now.

    • WiderMouthOpen's avatar
      WiderMouthOpen
      Esteemed Contributor

      That's rough. Been hearing about a lot of outages in AZ. I suspect it has something to with the heat but Phoenix has also been getting upstream OFDM upgrades so that doesn't help either. Is your internet up at least?

      Also, may I ask what brought you to the forums? Just making sure we aren't going to get a huge influx of posts from Chat sending outage victims to the forum.

      • Jip's avatar
        Jip
        New Contributor II

        I went to the Cox Store today and inquired about my seven day TV outage. They advised this was a known outage, something to do with a damaged "node." No other info. from them besides confirming Cox was aware and working on it. They did relate that other subscribers were also involved with random TV, internet, or both outages. (My fiber optic internet was not involved.)

        Turned on the TV upon returning home, and everything was back to normal service! Curiously amazing how these things work themselves out!

        Chat did not direct me to the Forum. I have checked the Forum frequently over the years regarding other issues. Lots of wisdom and good advice available on the Forum. For this particular issue I just decided to ask in the Forum for information, as Cox customer service and the Cox app did not provide any clues.

        Thank you, WiderMouthOpen, for your responses!