Forum Discussion

jdavidbaker's avatar
jdavidbaker
New Contributor II
2 months ago

Setting up Orbi WiFi Mesh with ipV6

Hi,

I'm trying to enable IPv6 but am failing to do so.  I have a Cisco DPQ3212.  If I set the Orbi IPv6 settings to "DHCP", I get an IPv6 address on the router but none of my devices inside get an IPv6 address.  If I set it to "Passthrough" (I saw in the forums to do that) but I'm not getting an IPv6 address on my computer and phone either.

My computer is a MacBook Pro, my phone is an Android.  If I go to https://test-ipv6.com/ on my phone on the cell network, I get an IPv6; but if I go to it while connected to the Orbi, I get no IPv6.

Is there any suggestions on what I need to do to get IPv6 working on my local computer?

11 Replies

  • jdavidbaker's avatar
    jdavidbaker
    New Contributor II

    Just to update anyone who might be reading this thread in the future, so far nothing I have done has allowed me to connect to an IPv6-only website, and I have given up as I have spent too much time trying to solve it already and all parties involved require me to pay for support, which it's not worth it to me.  Thanks to everyone who has replied for your help.

  • Hello, jdavidbaker 

     

    Our network is built in such a way as to manage IPV6 traffic from your devices seamlessly through your modem across the internet with no action on your part. What you're describing sounds like IPv6 on your home network, which would be configured on your router. If you can share why you would need IPv6 on the home network, perhaps a member of our community would be able to make recommendations.

  • jdavidbaker's avatar
    jdavidbaker
    New Contributor II

    Ok, maybe I'm not understanding how IPv6 works then, I thought with IPv6 every device gets assigned an ip even inside of a private network.  I'm not necessarily looking for that, but I do want to be able to visit IPv6 only websites like ipv6only.me - which is not currently working for me even when my Orbi router shows an IPv6 address.

  • jdavidbaker's avatar
    jdavidbaker
    New Contributor II

    Here is a screenshot of my Orbi IPv6 settings and the results of going to https://test-ipv6.com/.  I have redacted the IPv6 address but it shows that I'm getting something, but the IPv6 test shows "No IPv6 address detected."

     

    • ExtraChrispy's avatar
      ExtraChrispy
      Contributor III

      I'm not really sure how the Orbi does this but it sounds like you're not getting a prefix delegation.  I was trying to find more info on the User Class setting pictured but unable to.  If supported, I'd suggest configuring it to request a prefix delegation of /64 if you just have a single LAN.  This may very well require going back to Netgear support for further clarification.  Once you're successful, you'll see devices on your home LAN will obtain routable IPv6 addresses all with your /64 prefix delegation.

      Something else you could experiment with is turning on the LAN DHCPv6 server.  My equipment is a bit more sophisticated than what the typical home user has but in my case, DHCPv6 is how I distribute IPv6 addresses to my internal clients.

      • jdavidbaker's avatar
        jdavidbaker
        New Contributor II

        Hm, thanks for that info.  I can't figure out how to change the prefix delegation but that makes sense.  I noticed now that the section "Router's IPv6 Address On LAN" says "Not Available" - I'm guessing because I'm getting a /128 delegation.  Is that how Cox is doing the DHCP, a function of the modem, or a function of my router?

  • dlarkin-dc's avatar
    dlarkin-dc
    New Contributor III

    You might have to delete the Wi-Fi connection in the PC and phone, and then reconnect to force the LAN IPv6 be assigned. I've seen that be an issue with IPv6 before. Clients might also need to be set for IPv6 native mode.

  • Darkatt's avatar
    Darkatt
    Valued Contributor III

    do not setup your router as pass through, because that will not allow it to work properly. Honestly thse issue is on the orbi, I would contact Netgear, since they will supply you the support you need, and very quickly as they are trained on your device.